wiring diagram for a ford F-100, 1970 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-27-2002, 06:30 PM
Registered User
 
Join Date: May 2002
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post wiring diagram for a ford F-100, 1970

I was hoping someone could help me locate a wiring diagram for a 1970 ford F-100 truck.
Is there anything on the internet where a person could just download a diagram?
My F-100 keeps charging even when it is turned off.
I have had one battery explode and now the other one smells like sulfer.
I have replaced the altenator and voltage regulater, twice. There must be something in the wiring that is not right, at least that is the conclusion I have come too.
Any help or advice would be greatly appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-27-2002, 06:50 PM
johnnymopar's Avatar
Love your nails! You must be a Libra
 
Last photo:
Join Date: Dec 2001
Location: Stratford, ON, Canada
Posts: 599
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Talking

your alternator will not charge your battery if your engine isn't running. i think you've probably got a bad short somewhere. does your battery lose its charge all the time?

JB
__________________
"Well done is better than well said." - Benjamin Franklin (1706-1790)
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-27-2002, 09:50 PM
Registered User
 
Join Date: May 2002
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

The battery is overcharging even when the engine is not running.
In fact the headlights go dim and bright when the truck is driving or even when it is idle.
Hence the reason I really need a wiring diagram.
Thanks,
Musmly
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.