Wrong tailshaft bushing for T-5 manual? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-13-2009, 08:43 AM
Registered User
 
Last photo:
Join Date: Oct 2009
Location: Weatherby Lake, MO
Age: 57
Posts: 27
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Wrong tailshaft bushing for T-5 manual?

Bought the tailshaft bushing and seal kit from Carquest parts store. This is for a Tremec T-5 manual transmission. The seal looks correct, but the bushing is split its entire length. The bushing that is in the tranny now does not appear to have this split, and pictures of bushings on the internet do not appear to be split.

The bushing is of the proper size, but why the split. Not that it has ever happened before.. ..but did the parts house give me the wrong bushing?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-13-2009, 10:45 AM
Rexnfx's Avatar
Registered User
 
Last photo:
Join Date: Nov 2009
Location: Washington State
Posts: 140
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Bushing

They gave you a teflon coated bushing. It will work just fine. Many late model GM RWDs are using teflon coated converter hub and yoke bushings.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-23-2009, 07:10 PM
Registered User
 

Last journal entry: assembled
Last photo:
Join Date: Aug 2006
Location: ohio
Posts: 48
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have very good luck with a company out of Michigan. I believe their web site is thegearbox.org Very fast turnaround and he seems to be very helpful in getting you the correct parts.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
uh-oh. Wrong lube in manual steering box - what now? hotrodf1 Suspension - Brakes - Steering 6 07-17-2007 08:01 PM
Is the manual wrong?? woodworkerusa Electrical 3 03-19-2006 09:11 PM
TH350 Manual Valve Question Pantload Transmission - Rearend 6 02-19-2006 01:48 PM
G body with manual brakes - it works! - pics dh79 Suspension - Brakes - Steering 7 08-27-2005 10:55 PM
Th400 tailshaft problem, possibly driveline? L78Chevelle Transmission - Rearend 4 05-11-2004 07:49 AM


All times are GMT -6. The time now is 08:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.