Z-28, New Alternator and Battery, Sporadic Charging - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-18-2004, 04:00 PM
Member
 
Last photo:
Join Date: Jul 2003
Location: Chesapeake Beach, MD
Age: 53
Posts: 31
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Z-28, New Alternator and Battery, Sporadic Charging

I bought a 1986 Z-28 that someone put a nice 350 in. When they did it, they eliminated all the sensors (just like the good old cars) and left a massive amount of wiring harnesses taped-off. The alternator was putting-out 10 volts (bench tested) so I got a new one...I also put a known good battery in it. I started it up and the volt meter read 13 volts, thought I had it fixed. When I drove it, everything electrical was draining, and with the headlights on, the turn signals barely clicked...obviously not charging. I stopped, put it in neutral, and 13-volts once again. Drove it and it dropped to 8-10 volts. Battery terminal posts are clean and so are the cable connections. The alternator is charging, sometimes. Sound like a ground?

    Advertisement
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.