Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Ask as I go bbc thread
View Single Post
  #112 (permalink)  
Old 05-10-2019, 12:40 AM
Dfish1247 Dfish1247 is offline
Registered User
 
Join Date: Nov 2016
Location: Kingsport,tn
Posts: 284
Wiki Edits: 0

Thanks: 42
Thanked 41 Times in 40 Posts
I know the galley plugs are in, I saw them before I put the timing cover on. I didn't mic the depth or anything, surely to God the machine shop wouldn't screw that up.

Shouldn't I at least show some pressure just from the pump overcoming the filter and/or filter bypass? I am showing 0, and this gauge does work. Heck, I can't even get the gauge reducer fitting to leak, and i barely tightened it on purpose just to see. I didn't see any wear marks on the gears or the pump housing either, I figured I'd at least see something.

If I remember, the only weird rear cam bearing was on the 65-67 396 blocks, something about a groove in the rear bearing, but the 427-454 blocks took regular bearings.

They didn't mention anything about grinding clearance for the crank, and it's not on the receipt. Believe me, every finger movement got billed. Unless you mean 4.5" or bigger stroke.

I bit the bullet and ordered a moroso hv pump and another pickup, the other one is welded on, so it's toast. I have the hardened driveshaft already, so we'll see what happens, I'm not off again till Tuesday, so hopefully it'll show up by then and I'll try it out.

Just a real frustrating situation. My dad laughed and said " Now you know why I don't fool with this [email protected]&/ anymore"
Reply With Quote