Car stumbles badly - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-10-2019, 02:33 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
Car stumbles badly

This is a mut, so the problem could be a couple things. It's a SBC 350. I get it tuned, runs strong in driveway, take it to the street and romp on it and it stumbles at about 5k rpm. Stumbles as in it's out of fuel or something and then continues that when I try to get on it again. can drive it back home, idles fine, runs fine.

Is there something in the carb that could have a blockage?

Also have a MSD 6al ignition with mechanical dizzy and holley 650 mechanical carb. The rev limiter is not set up, but could that have something to do with it, or the dizzy have moved a bit?

I've changed the (electric) fuel pump, lines, filter etc. and have one of those cheap pressure regulators from autozone that you can turn the dial from like 1-6 for fuel pressure, which I have set at 5.

thanks in advance.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-10-2019, 03:00 PM
Registered User
 
Join Date: Jan 2012
Location: Grand Rapids, MI
Posts: 2,065
Wiki Edits: 0

Thanks: 219
Thanked 426 Times in 347 Posts
I don't have anything nice to say about a Mr. Gasket fuel pressure regulatior.

I would start by installing a gauge after that pos regulatior to see what your true reading is and how much variation you are getting.

I can almost guarantee that once warm that regulstior is allowing to much fuel through flooding the car.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-10-2019, 03:25 PM
Registered User
 
Join Date: Apr 2007
Posts: 12,573
Wiki Edits: 0

Thanks: 218
Thanked 1,194 Times in 946 Posts
Could be a lot of things but before I started spending money I'd recomment tightening up the plug gap to .030 to .035 inch. The next step would be to take the 6AL out of the circiut to see how it runs on a simple HEI.

These are tests that take a little of you time but are otherwise freebies.

Super wide plug gaps aren't necessary nor really desireable especially with high compression and overly rich mixtures.

6AL boxes introduce weird problems at times. The do demand that the heads and intake have seperate grounds, lacking these the high and abrupt energies fed to the plugs can and do mess up the electronics in their search for ground.

Bogie
Reply With Quote Quick reply to this message
The Following User Says Thank You to BogiesAnnex1 For This Useful Post:
Onepieceatatime7 (07-10-2019)
 
  #4 (permalink)  
Old 07-10-2019, 03:33 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
Quote:
Originally Posted by cerial View Post
I don't have anything nice to say about a Mr. Gasket fuel pressure regulatior.

I would start by installing a gauge after that pos regulatior to see what your true reading is and how much variation you are getting.

I can almost guarantee that once warm that regulstior is allowing to much fuel through flooding the car.
It's mounted right by the passenger side valve cover on the fire wall, so it probably does get heated. Could flodding cause it to stumble as in, someone turned of the switch?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-10-2019, 03:37 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
Quote:
Originally Posted by BogiesAnnex1 View Post
Could be a lot of things but before I started spending money I'd recomment tightening up the plug gap to .030 to .035 inch. The next step would be to take the 6AL out of the circiut to see how it runs on a simple HEI.

These are tests that take a little of you time but are otherwise freebies.

Super wide plug gaps aren't necessary nor really desireable especially with high compression and overly rich mixtures.

6AL boxes introduce weird problems at times. The do demand that the heads and intake have seperate grounds, lacking these the high and abrupt energies fed to the plugs can and do mess up the electronics in their search for ground.

Bogie
I don't know that I even have the alum heads and intake grounded. It's grounded from the frame to the block. It's a points distributor, and the gaps are about .40 if I recall.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-10-2019, 04:32 PM
36 sedan's Avatar
Registered User
 
Join Date: Apr 2016
Location: American Canyon, CA
Posts: 1,089
Wiki Edits: 0

Thanks: 641
Thanked 315 Times in 251 Posts
What is the spark limiter set at in the 6AL?
JMHO, fuel pressure regulators work better as close to the carb as possible.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-10-2019, 04:43 PM
Registered User
 
Join Date: Apr 2007
Posts: 12,573
Wiki Edits: 0

Thanks: 218
Thanked 1,194 Times in 946 Posts
Quote:
Originally Posted by Onepieceatatime7 View Post
I don't know that I even have the alum heads and intake grounded. It's grounded from the frame to the block. It's a points distributor, and the gaps are about .40 if I recall.
6AL is what has my attention points are just a switch in this case. Problem with grounding is these things seek ground through whatever they can find which is sometimes back through the electronis of the 6AL, using an HEI just adds another possibility. Not to say this is the issue but solving for the simple first can save a lot of money, if it isn't the problem you're just out some time not time and money.

The block ground is for the starter and mild electrical fields that are DC in nature, even the heads are pretty safe with this bonding to the block with sealant laden bolts and gaskets. The 6AL in not so kind, it is shocking the plugs with a high energy square wave pulse that is hard to absorb through these unintentional connections. Running the heads and intake together with some number 10 wire to the frame or battery negative post insures the ground side of the plugs doesn't find a sneak circuit back through the electronics. This recommendation is nothing new it usually can be found in MSD's instructions but not always it seems to come and go on reprints.

One has to realize that electrical currents move in voltage differentials not adsolute this side is hot and that side not. The left over currents from firing the plugs will take a positive 12 volt circuit to ground if a negative bonded route is not available. Smoking 6AL's, HEI's or capacitors on points is not all that uncommon.

I'm kind of leaning toward electrical rather than fuel pressure since you're not reporting a backfire with this but just a stumble. If it flames out the intake that puts both options on the table, if it doesn't that's a pretty good indicator but not absolute that the mixture is hanging in there.

My prefered electric pump layout is of course more expensive but for a carb I really like to run a lower pressure TBI rated pump for factory TBI using about 15 psi. Then a bypassing regulator with preferably a tank return but tee'ing in the feed line just ahead of the pump if it's back by the tank is OK, you first want some distance to let the pump bypass fuel to cool before being pumped again. This insures a managed oversupply of fuel in the system for a consistent supply at the carb so at high RPMs it doesn't start to lose fuel pressure as demand over runs supply. For a turbo type pump it insures there is always a fuel flow for cooling the motor, it never encounters a near deadhead situation when idleing as happens with a non-bypass regulator.

As for gauges everybody's quality is sucko, price is no indicator of quality. I have a new Stuart Warner vacuum gauge that reads 24-25 inches at a 750 rpm hot idle vacuum on a 350 with a LT4HOT cam, 1.6 rockers, with 10.3 SCR. My old quick and dirty Harbor Freight vacuum/boost gauge with multiple color LED lighting says 16-17 inches, so does my motorcycle multi-carb adjusting mercury manometer.

I also run a Mr. Gasket fuel pressure gauge at the regulator it is set for about 5.7 to 5.8 psi regulated line pressure on the left side inner fender and also a no name mini gauge in the line at the Edlebrock carb which reads about 5.5 psi.

Bogie

Last edited by BogiesAnnex1; 07-10-2019 at 04:53 PM.
Reply With Quote Quick reply to this message
The Following User Says Thank You to BogiesAnnex1 For This Useful Post:
36 sedan (07-10-2019)
  #8 (permalink)  
Old 07-10-2019, 05:02 PM
Registered User
 
Join Date: Jul 2004
Location: At Speed
Age: 56
Posts: 2,996
Wiki Edits: 0

Thanks: 334
Thanked 433 Times in 382 Posts
do you know that the valves springs are correct for your setup?

Points floating out is also possible.

is the pump by the fuel tank?
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-10-2019, 05:09 PM
36 sedan's Avatar
Registered User
 
Join Date: Apr 2016
Location: American Canyon, CA
Posts: 1,089
Wiki Edits: 0

Thanks: 641
Thanked 315 Times in 251 Posts
Quote:
Originally Posted by 36 sedan View Post
What is the spark limiter set at in the 6AL?
I meant to say REV limiter. 6al has rev limiter that requires setting, i believe default setting is 5k.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-10-2019, 06:17 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
Ok but this is going to sound stupid. I just hooked up a new timing light that works with msd and am timing of the # 6 cylinder....yeah I know.

It ran ok before but a bit hot and had the stumble, but and it appears the timing was set after Tdc.

Net net.

Itís set at 8 degrees initial with a 21 degree total timing stop in the dizzy. Hereís the thing. Itís holding 185 temp in a 100 degree weather now and a had hot issues before. At idle. I have 15 psi vacuum and she jumps when you stomp it, but will not test tonight due to bud light.

Is 8 degrees initial and 29 total ok??......cause the motor suuuuure seems to like it.

Iíll double ground as suggested either way.

8 degrees initial??

Any more than that and she wants to buck a little on start.

Itís 350 , .40 over, zero deck
10.5 compression
Roughly .40 gap on plugs
E street alum heads
Roller rockers
Low rise single plane intake ..... I know, I know...
Shorty headers
650 carb
All mechanical carb, dizzy, manual tranny etc.

So, is 29/30 total timing sound ok?

The temp and vacuum at steady 15 or so make me want to leave it.

I just got vacuum gauge and new timing light.

I donít think the msd box rev limiter is an issue as I have no tach yet, but I did set the dials today @ 6200 to be sure
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 07-10-2019, 06:19 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
Temp holding at 185 I should say, which is much better
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 07-10-2019, 06:22 PM
Registered User
 
Join Date: Jan 2019
Posts: 58
Wiki Edits: 0

Thanks: 8
Thanked 1 Time in 1 Post
268h comp cam
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 07-10-2019, 06:40 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 53
Posts: 17,675
Wiki Edits: 0

Thanks: 273
Thanked 3,211 Times in 2,693 Posts
Total timing at 29-30į may leave a little power on the table, it may prefer the total up near 32-34į for maximum power.

That means with your set-up the initial would need to be 10-12, maybe 14į initial. If it fights the starter too much check your ground connections and battery main cable sizes, Typical parts store battery cables are too small to carry the load well.
If that checks out, you may want to investigate installing an ignition interrupt toggle switch, so you can roll the motor over with the starter easer with no ignition firing, then throw the ignition power on. It helps a bunch with slow cranking cars.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 07-10-2019, 06:44 PM
36 sedan's Avatar
Registered User
 
Join Date: Apr 2016
Location: American Canyon, CA
Posts: 1,089
Wiki Edits: 0

Thanks: 641
Thanked 315 Times in 251 Posts
Quote:
Originally Posted by Onepieceatatime7 View Post
Ok but this is going to sound stupid. I just hooked up a new timing light that works with msd and am timing of the # 6 cylinder....yeah I know.
Why are you connecting your timing light to #6 instead of #1?
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 07-10-2019, 07:02 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 53
Posts: 17,675
Wiki Edits: 0

Thanks: 273
Thanked 3,211 Times in 2,693 Posts
Quote:
Originally Posted by 36 sedan View Post
Why are you connecting your timing light to #6 instead of #1?
Doesn't matter, it will time the same on #1 or #6 because they are both at TDC at the same time.
Often racers will use #6 if #1 plug or wire is in a location that is harder to get to or easier to burn wires on. It's just a convenience thing.
Reply With Quote Quick reply to this message
The Following 2 Users Say Thank You to ericnova72 For This Useful Post:
36 sedan (07-10-2019), 55 Tony (07-15-2019)

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.