MustangII Front end problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-31-2015, 09:33 AM
Registered User
 
Join Date: Feb 2014
Posts: 2
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
MustangII Front end problems

Have a 33 Ford with MII front end. Put new calipers, pads, and master cylinder and bled all lines. When you apply brakes, the front calipers on both sides will not release until vehicle sits for awhile and then they release and you have to pump the pedal to get pressure and they freeze again! Could it be a bad proportioning valve? Any assistance would be appreciated!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-31-2015, 10:13 AM
33Willys77's Avatar
Registered User
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 838
Wiki Edits: 0

Thanks: 21
Thanked 132 Times in 128 Posts
make sure you rod going into the master is not too tight - may not be releasing all the way. Could have dirt in the line - plugging a passage back into the master or proportioning valve. Pumping to get pressure means there is air in the line.
Reply With Quote Quick reply to this message
The Following User Says Thank You to 33Willys77 For This Useful Post:
kipton66rodder (07-31-2015)

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
67 C-10 with some front end problems stempy4930 Suspension - Brakes - Steering 7 10-01-2012 10:17 AM
T-350 Front end play problems bigorangechevy Transmission - Rearend 11 06-02-2011 03:41 PM
1933 Chevy front end problems Tubbed71 Suspension - Brakes - Steering 11 08-23-2009 05:22 PM
Front end mock up shows some problems, cut n weld or frame shop? Ripped Body - Exterior 9 11-26-2005 07:03 PM
front end problems tonylsg Suspension - Brakes - Steering 13 04-15-2003 06:47 PM


All times are GMT -6. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.