Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> Paint> PPG epoxy failing
User Name
Password
lost password?   |   register now

Thread: PPG epoxy failing Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-21-2018 03:31 PM
TerryH Thanks for your reply, st3gamefarm. Anyone that has had DP-90 separate after applying to the car, or has noticed that DP-90 doesn't dry as quick as it's advertised and is causing problems... please encourage them to contact me. [email protected]
05-19-2018 05:40 PM
st3gamefarm
Quote:
Originally Posted by deadbodyman View Post
I don't use urethane primers very much so when I did I just ran down and got a quick qt of omini 2k it seemed like pretty good stuff to me, that is until I saw how bad it shrank on a black truck I did. It looked great for a while, only it seems to shrink for months but very slowly, after a year or two its pretty noticeable.(if that makes any sense). I had to toss the omini 2k primer and chalk up another one as junk not to buy. I should have known better but my guy that delivers my materials doesn't have qts just gallons of primer and about a qt got wasted because it was just too thick to use after a while. Now I take the time to clean the top of the can and seal the primer up well so it lasts longer.
I've had failure with Omni 2K PPG rep paid for the re-do. Paint comming off in sheets, with powder primer residue on it. Car had not even left the shop yet. Hadda strip, and re-prime, with something else. I chose to use Slick Sand on the second go 'round, paint has held up now for about 10 years.

I used DP for many years, it was the "Cat Daddy". DPLF OTOH is crap.
I used Sikkens Autobase for years, was good stuff, prime formula would match perfect. They took out my system, and replaced it with Autobase Plus. I was sorely disapointed with it, and went to Global. While Global is good stuff, It's kinda expensive. And sometimes it's more cost effective to order a pint of DBC, than to mix 8oz of BC.
I've been using 2002 clear since it came out, and just love it. But I tried SPI universal a couple years ago, and found that I like it as well.
I'm still up in the air about SPI epoxy, While it seems to be good stuff, I've had a couple of issues crop up recently, and I cannot say definitevly what the cause is, untill I get into the repair. Both issues, are on my own vehicles, so it will be a while before I get to that.
I will say this though, steer clear of Nason if you want a quality job that will hold up for a long time.
04-19-2018 01:11 PM
TerryH Rustyfender - Could you please contact me regarding this PPG epoxy from 2016? I'd like to ask you a couple questions if you don't mind as I'm having a major issue on a very expensive show car of mine where the painter used PPG epoxy. Please contact me if you can! 205-263-5102. [email protected]
04-19-2018 01:08 PM
TerryH
Regarding user "Rustyfender"

I know this is a long shot here, but would anyone have the contact info for Rustyfender should you have had previous discussions with him? It is very important that I get in contact with him regarding his experience with this PPG epoxy failure as I'm having some major issues with the company as well and would like to speak with him to ask him a couple of questions regarding his experience with it.

Please let me know if any of you can. Would like to have Rustyfender give me a brief call to discuss if possible! 205-263-5102. - Terry H., Birmingham, AL
04-18-2018 12:45 PM
dusterdude3404 Yea,the lead free dp sucks

Sent from my R1 HD using Tapatalk
04-18-2018 11:35 AM
TerryH
Quote:
Originally Posted by st3gamefarm View Post
I agree the DP isn't what it used to be. and the Omni 2k is not what it should be. I've had several failures from it on different vehicles. Most of which were evidenced by the paint comming off in sheets, and the primer beneath being powdery. I don't use it anymore.
I just found this forum. I would love to talk to you about your issues with PPG. I have a very expensive show car where the paint has been coming off in sheets due to PPG and DP90 failure. Please give me a call to discuss if you don't mind. My number is 205-263-5102. I'm in Birmingham, Alabama.

Thank you! - Terry
04-18-2018 11:31 AM
TerryH
Quote:
Originally Posted by Rustyfender View Post
I am a hot rod shop out of GA and have used PPG for over 30 years with no real problems till lately. The DP epoxy line that we have all used forever is failing me, before the LF or lead free label hit the can it would stick to plate glass around probably around 1998 after that it had to have more cure time before top coat which as of late is at least 24 hrs. But now even at that will pull loose from sandblasted metal, bondo, plastics and sanded metal. I'm even seeing cars at shows where this seems to be a problem any one else experience this as well ???
Rusty -

I am experiencing this same issue on a very expensive show car. Around the time that your post is dated is when this started occurring. This is not an isolated incidence. I have been looking for other people that have had this similar problem. I would LOVE to talk to you on the phone to discuss more. Would you be willing to give me a call at 205-263-5102. I'm in Birmingham, Alabama. I look forward to hearing from you soon! - Terry
07-18-2016 06:14 PM
st3gamefarm I agree the DP isn't what it used to be. and the Omni 2k is not what it should be. I've had several failures from it on different vehicles. Most of which were evidenced by the paint comming off in sheets, and the primer beneath being powdery. I don't use it anymore.
06-28-2016 07:40 AM
deadbodyman I use the same products as Kelly for about 10 yrs. and loving it.
06-25-2016 09:58 PM
carolinacustoms If you are concerned about compatibility, I use SPI epoxy and urethane primers, as well as SPI universal clear coat, all with PPG base coats and have not had any issues with any of the above combinations. I do recommend the SPI base coats if you have the chance to use one of their colors. For a general process, we 80 grit bare metal with a DA and then clean with waterborne then solvent based W&G remover and apply epoxy.

Kelly
06-23-2016 04:10 PM
shine one of my old ppg tech manuals has k36 in it. it was in the kondar days. this manual is from around 84 .
06-23-2016 08:09 AM
Rustyfender I believe its a combination of the DP not being what it was and the shrinkage of 36 but I don't believe ancient technology because these things used to work great. Newer tech seems to be the problem from what removed they claim EPA ? I am looking at the products ya'll have brought up and will try, I have been PPG tried and true so not schooled on these and the reason for the post. PPG said to use DX 1791 But P sheet says not to use on media blasted steel or on boy filler so that's stupid for restoration ! Thank for all input I really need it gonna have to swap to something.
06-23-2016 07:32 AM
shine i no longer use urethane primer but the turbo is good.
06-23-2016 06:43 AM
deadbodyman You like the turbo primer? I never tried it. hows it compare to the standard 2k primer?
06-22-2016 06:42 AM
shine drop the dplf and k36 . switch to spi epoxy and the turbo primer. k36 is ancient technology anyway . primers from the 80's were horrible about shrinkage .
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:31 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.