Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Never ask "What else can go wrong?"
User Name
Password
lost password?   |   register now

Thread: Never ask "What else can go wrong?" Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-14-2005 07:06 PM
Hippie
Quote:
Originally Posted by dinger
about 8 cans of that Miracle tranny fixer-upper ought to git r done...
I got a bad feeling it's already had a "pop top" overhaul.............. IF ya' know what I mean.
08-14-2005 05:32 PM
dinger about 8 cans of that Miracle tranny fixer-upper ought to git r done...
08-14-2005 04:35 PM
WakBordr7387 Sorry to hear that hippie, Its never cool when you have problems one after another. I just had my truck go through a few problems that maybe leading up to a big problem.


Brad
08-14-2005 04:24 PM
Hippie
Never ask "What else can go wrong?"

This has been a year of one minor auto repair (under $300) after another at our house and then the engine in our '99 Alero had to be replaced a couple weeks ago. NOT so minor. I had to drive my Monte for a week and a half while the Olds was in the shop and at 50 miles a day and 13 MPG that hurt. Got the Olds back and parked the Monte until today. I pulled it out, did some of the repairs I had been putting off on the interior and shined it all up. I scrubbed the vinyl roof and had it looking as good as it has since buying it in February. I decided to run to the next town and halfway there passed a mini van that couldn't decide what speed it wanted to go. It felt kind of sluggish when I got alongside but then came out of it. I parked it and went into the store, when I came out I backed out of my parking spot and put it in drive and it revved up and barely started moving. Finally it started rolling but was definitely slipping. Got it out on the highway and once in drive it seemed to be OK. When I got home I checked the fluid and it was full but grayish black, about the color of clutch material. Doesn't smell burnt though. I started it up and pulled it around to the garage and it was OK but I think the damage is done. I have wanted to swap a 200-4R into ever since I got it but with the hit on the budget from the Alero incident it looks like the Monte may be a garage decoration for a few months. At least I have a good reason to give the Boss for a new 200-4R though!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.