Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Skip White Heads BBC
View Single Post
  #147 (permalink)  
Old 06-10-2019, 06:06 AM
55 Tony's Avatar
55 Tony 55 Tony is offline
Registered User
 
Join Date: Nov 2018
Location: Cocke County, TN
Posts: 1,199
Wiki Edits: 0

Thanks: 139
Thanked 209 Times in 185 Posts
First off, the 7.77's were with the old heads and hooking great. New heads were running 8.05 but it wasn't hooking, 60' was 1.95 but again not hooking. I asked but no one responded to my question of the possibility of the track being too hot. It was sunny and in the high 80's. I think, but I'm not sure, if it had been hooking it would have been running about the same or at least a little better than the old heads.
The cam is advanced 2*, which was done when it had 3.42 gears and an almost stock converter.

The best I could measure the deck height was about .020, it was tough to measure since the only flat part of the pistons is on the inner and outer sides, so I measured both and averaged them. I couldn't measure above the wrist pins due to the dome. I just noticed now, they updated the piston info at summit and it now says .025" deck clearance, it didn't say that when I bought the pistons, a tech at speed pro told me after the fact. I did notice on the right side of the block I could read some type of number stamped in the front of the deck surface, so if anything was taken off the deck it wasn't much. The static compression ratio with the old heads was lower than I thought, found that after cc'ing them. The current setup is at about 9.75:1 If it matters, the cam calls for 9.5:1 or more.
__________________
Young enough to learn ... too old to remember.

Last edited by 55 Tony; 06-10-2019 at 06:16 AM.
Reply With Quote