super budget 92 camaro turbo build - Page 8 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Projects/Builds/My Ride
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #106 (permalink)  
Old 06-02-2014, 09:57 AM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
car went 12.50's all day yesterday in the heat and altitude still launching off idle with low 2.xxx 60's

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #107 (permalink)  
Old 06-02-2014, 10:02 AM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 61
Posts: 12,327
Wiki Edits: 0

Thanks: 872
Thanked 1,463 Times in 1,353 Posts
what were you running last year?
Reply With Quote Quick reply to this message
  #108 (permalink)  
Old 06-02-2014, 10:13 AM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
Quote:
Originally Posted by vinniekq2 View Post
what were you running last year?

12.80's with more boost , 1.7 60's

hes still breaking in the engine , it will be in the mid 11's once he stops babying it

with a larger turbo the combo is proven to run mid 10's

he has a gt35 on it still , guys witht he same exact combo running a gt42 series are well into the 10's
Reply With Quote Quick reply to this message
 
  #109 (permalink)  
Old 06-02-2014, 10:19 AM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 61
Posts: 12,327
Wiki Edits: 0

Thanks: 872
Thanked 1,463 Times in 1,353 Posts
breaking it in? thats after the first filter change,,,,jump on it.(unless you are not sure if its assembled correctly)?
If its going to let go,it would have already,,,,,
Reply With Quote Quick reply to this message
  #110 (permalink)  
Old 06-02-2014, 10:30 AM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
Quote:
Originally Posted by vinniekq2 View Post
breaking it in? thats after the first filter change,,,,jump on it.(unless you are not sure if its assembled correctly)?
If its going to let go,it would have already,,,,,

hes still gunshy , he broke a piston last year and hes a points racer so he doesnt want to risk hurting it at all as he normally places very well in the points standings , a breakdown would cost him the season.

as he gets used to the new combo he will start to lean on it
Reply With Quote Quick reply to this message
  #111 (permalink)  
Old 06-02-2014, 11:43 AM
Registered User
 
Join Date: May 2009
Location: Wichita KS
Posts: 495
Wiki Edits: 0

Thanks: 0
Thanked 20 Times in 17 Posts
Nice! What kind of MPH?
Reply With Quote Quick reply to this message
  #112 (permalink)  
Old 06-02-2014, 12:00 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
Quote:
Originally Posted by ForceFed86 View Post
Nice! What kind of MPH?
110-112mph
Reply With Quote Quick reply to this message
  #113 (permalink)  
Old 06-24-2014, 04:33 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts






hes starting to go rounds with it now , still in no hurry to break into the 11's though
Reply With Quote Quick reply to this message
  #114 (permalink)  
Old 07-23-2014, 10:43 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts


he ran a bunch of 12.60's with the cars ignition system breaking up off the line and down track in high gear


on this run he shut it off at the 1000ft mark due to the ignition system and went 13.0 @ 109
on a side note both drivers are on that tree like flies on poo
Reply With Quote Quick reply to this message
  #115 (permalink)  
Old 08-09-2014, 09:53 PM
Registered User
 
Join Date: Mar 2009
Location: PNW
Posts: 174
Wiki Edits: 0

Thanks: 18
Thanked 7 Times in 7 Posts
Just curious, if starting from ground zero. Would you go with a bigger 60* six?
Like a 3.5. I know its your buddies but curious on your thoughts.
Considering a 60* V6 swap in my 66 Volvo wagon. Turbo of course!
Reply With Quote Quick reply to this message
  #116 (permalink)  
Old 08-10-2014, 01:19 AM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
Quote:
Originally Posted by Nonhog View Post
Just curious, if starting from ground zero. Would you go with a bigger 60* six?
Like a 3.5. I know its your buddies but curious on your thoughts.
Considering a 60* V6 swap in my 66 Volvo wagon. Turbo of course!
3.4 if ur using a rwd engine, if u have the option to use the fwd engine the 3.5 and 3.9 engines are very good canidates, the 3.9 is alot harder to swap due to some features of that engine

take a 3.5L cam it and slap on a decent sized turbo and it will run mid 10's in a 3,000# car at around 12 psi. of course this includes having the proper drivetrain and supporting parts


all depends on what u want the end result to be and what the cars main function would be

the car in this thread will turn up the boost after aug 30th as thats his last points race, pending the transmission holding the car should run mid to high 11's pretty easy witht he stock 700r4 and 108$ autozone converter that is slipping pretty badly
Reply With Quote Quick reply to this message
  #117 (permalink)  
Old 08-31-2014, 04:07 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
12.25 at 114mph first pass today , he still at the track so will update later and have video /slips to post
Reply With Quote Quick reply to this message
  #118 (permalink)  
Old 08-31-2014, 04:14 PM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 61
Posts: 12,327
Wiki Edits: 0

Thanks: 872
Thanked 1,463 Times in 1,353 Posts
could go 11s with that mph,especially with a small engine
Reply With Quote Quick reply to this message
  #119 (permalink)  
Old 08-31-2014, 04:54 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts
Quote:
Originally Posted by vinniekq2 View Post
could go 11s with that mph,especially with a small engine
im pretty sure that was off the footbrake, as hes still having a bog issue when using the antilag , that being said he cut his first 1.6 60' off the antilag 2 weeks ago even with the bog and the car picked up 4 mph , it usually goes 1.8-1.9 off the footbrake , so 1.5 60's should be the normal once the antilag is fully functional

if he can get it to work today car might just run an 11.80's @ 119 ish
he still hasnt turned the boost up yet either , i gave imsome things to change on the antilag so well find out later today
Reply With Quote Quick reply to this message
  #120 (permalink)  
Old 08-31-2014, 05:06 PM
Project89's Avatar
Registered User
 
Join Date: Oct 2011
Location: utah
Posts: 1,347
Wiki Edits: 0

Thanks: 16
Thanked 173 Times in 131 Posts


was footbraked , its a points race , last one of the year so he wont be leaning on it during the rounds, he cant use the antilag in eliminations anyways .

starting next weekend he is going to really work on the antilag , ill post updates as i get them
Reply With Quote Quick reply to this message

Tags
build thread, camaro

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
twin turbo 350 on a budget?? mikeweyman Hotrodding Basics 24 11-16-2010 12:03 PM
Thrush Turbo or Dynomax Super Turbo? henkelphoto Engine 3 08-25-2006 12:46 AM
budget turbo set up 409guy Engine 12 08-22-2006 06:40 PM
Turbo VS Super Icebergslim1827 Engine 29 04-24-2004 10:52 PM
super/turbo madhat Engine 0 06-22-2003 02:15 PM


All times are GMT -6. The time now is 11:42 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.