Unilite ignition problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans Advertise
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-30-2011, 03:07 PM
Registered User
 
Join Date: Oct 2011
Location: Pooler Ga.
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Unilite ignition problem

The unilite ign. with pertronics pickup in my 302 (95) is giving me a fit. i notice that in other posts Ive seen there are three wires coming from the dist. mine has 1 black 1 red no others. The engine has an intermittent miss as the engine is throttled hard. but not all the time, it varies from day to day. this is a non vacuum dist. with new wires, plugs, coil, and new wiring harness (yes the problem was happening before the wiring harness change). Most of you don't seem to care for the unilite setup so what do you suggest.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-30-2011, 03:16 PM
BOBCRMAN@aol.com's Avatar
Registered User
 
Join Date: May 2002
Location: Holly, michigan
Posts: 9,049
Wiki Edits: 0

Thanks: 113
Thanked 572 Times in 489 Posts
It could also be a valve spring or valve guide/seat going away..
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-30-2011, 03:33 PM
Registered User
 
Join Date: Oct 2011
Location: Pooler Ga.
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I hope not, roller motor with dart heads and all the right stuff. this thing is street driven and never abused, about 22,000 miles and well maintained. I never even thought about a mechanical issue.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mallory Unilite Ignition Issue hulk21074 Electrical 22 05-02-2017 05:13 AM
95 Camaro fan switch problem / ignition key problem human_forklift Electrical 12 05-29-2015 07:57 PM
Mallory Unilite Electronic Ignition Distributor 64Joker Engine 4 09-17-2006 06:46 PM
Mallory Unilite Problem frankenvette Engine 3 06-03-2006 05:29 PM
Mallory Unilite Ignition System loiselle Electrical 6 04-29-2006 06:03 AM


All times are GMT -6. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.