Hot Rod Forum banner
1 - 3 of 3 Posts

·
OFMF
Joined
·
42 Posts
Discussion Starter · #1 ·
Greetings all,

I have a 70 Monte that i am restoring and I want to take the engine compartment wiring harness off the firewall. There is a 3/8" bolt in the center of the main connector ( I believe that this connects to the fuse panel) on the firewall to the left of the steering column. Before I pull the bolt and start pulling/prying the connector, I was hoping to get some tips on just how to do this without messing up the connector. I would be greatly appreciated if someone could post a pic or 2 of the connector and how it comes apart. Thanks in advance for your help.

Pat
 

·
Registered
Joined
·
10,928 Posts
You are correct, that bolt is what holds the firewall wiring harness connector to the back of the fuse panel. It is just a bunch of spade connectors that match up to plugs on the back of the fuse panel. Unscrew the bolt and you should be able to just pry off the connector. Once it is off you may see some corrosion on the back of the connector, just clean it off as much as possible and apply some dielectric grease to it before reassembling it.

Vince
 

·
OFMF
Joined
·
42 Posts
Discussion Starter · #3 ·
Thanks 302,

Just like you said - right down to the corrosion in the lower left corner. It was stuck a little but it came off fairly easy. Thanks again for the help. Now for the dirty work. Here's a few pics of my progress so far.







Also found the reason why I could not get much air flow through the AC


 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top