Hot Rod Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
I have a 1974 351 windsor i put new carb. new feul pump and put 302 heads on it. the problem im haveing is when u give it gas it stumbles but idles perfect sounds great and just hit the key and it start. I never been stuck like this before i need help. If you hold gas pedle to floor its studders real bad like timming off but i checked it 3x its dead on.can someone help me plz.
 

·
Grumpy Old Goat Herder
Joined
·
1,397 Posts
It may be a vacuum problem, but I think that it is more likely a fuel delivery problem. Check your fuel filters, including the one in the carb, if applicable. Also check your fuel pressure from the pump.

Bill
 

·
Administrator
Joined
·
8,552 Posts
X 3 it sounds like a fuel starvation problem. Start b y checking fuel volume from the new pump.Even if it is new it may not be delivering, the sock in the gas tank may be plugged.
work from there to determine if the carb is getting fuel, maybe the float is stuck or set WAY to low. New doesnt allways mean good. I found that out a few times.:D
 

·
WFO
Joined
·
5,030 Posts
I have a 1974 351 windsor i put new carb. new feul pump and put 302 heads on it. the problem im haveing is when u give it gas it stumbles but idles perfect sounds great and just hit the key and it start. I never been stuck like this before i need help. If you hold gas pedle to floor its studders real bad like timming off but i checked it 3x its dead on.can someone help me plz.
Is the firing order correct? Ford numbers their cylinders differently and there are two different orders for the 302/351W.
 

·
Registered
Joined
·
152 Posts
You probably should check your point gap. I think it should be .017, as the rubbing block wears down it tightens the gap and retards the timing. Also it's very important to torque sbf intakes properly (inside out).
 

·
Registered
Joined
·
18 Posts
Sometimes the outer ring of the harmonic balancer slips, even though it reads perfect the engine is running with retarded timing. This would cause the hesitation.

You can verify TDC with a degree wheel and a piston stop or simply advance the timing until you get some spark rattle (detonation), then retard the timing just enough to eliminate the rattle.
 

·
Registered
Joined
·
5,784 Posts
accellerator pump ?

Is the Accelerator pump squirting when you look down the carb, engine off and open the throttle, are the throttle plates seated correctley , poor transition between idle and run, sometimes the carb needs rework. and I know some 351 and 302's use different head bolts. dowell pins and indexed correctly, Manifold fit. ?
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #13 ·
yes brand new carb everything working on carb, and yes the correct intake and gaskets. I'm thinking something electrical now, have 6.3 fuel pessure. it idles great starts without touching gas pedal.
 

·
Registered
Joined
·
5,391 Posts
I have electronic ign. and i can't hookup vacuum advance if i do it will shut down the engine.Thnx for everyones help.
Ford OEM distributor vacuum advance is always below the throttle plates - ported vacuum and is virtually '0' in Hg at idle. Full vacuum will give you possibly 20 or more degrees of advance at idle with it hooked up. MSD is also set up the same as Ford with ported vacuum and way beyond what a 351W will handle.

302 heads on a 351 may give you too much compression ratio.58- 60 cc 302 chambers vs 65-70 for a 351
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #15 ·
problem solved

I would have never believed what the problem was. The Ignition Module showed good when tested but a good friend said that dont mean its good. I bought a new Ignition Module today and truck runs perfect. thnx for all the advice everyone. I never had been stumped like that before I was pulling my hair out.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top