Hot Rod Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
89 K5 blazer TBI sbc . I find myself throwing my hands up more than not on this little big project truck....b4 reading take into consideration I'm no pro with electrical side of things, once it gets more then these TBI fuel injection electric fuel pump I turn around for my 78 Monte with the SIMPLE roots..so..I live here in Ken-tuck-aye so y'all get an better idea of situation . I don't got a garage I live in a trailer park that don't condone vehicles setting broke dwn nor do they allow major overhaul/ large scale messy mechanics/ or good ole fashioned slangin grease n knuckle bustin./ ..(champagne taste , M.D.20/20 budget community here)
first off, was told engine was replaced (reckon other threw a rod)
Truck was ran as some kids "Mud Toy" .
He then parked under the infamous "shade tree"
...n now I bought the results....

So there's wires and clips and wire looms with no apparent home to them providing dead ends for me thus far.. I've got the injectors on top but then, my bracket holding the sensors is were problems begin.
The little blue wire that clips in at bottom-side of tbi can't recall what it's called right off hand. (?) *clip there, but, then CUT* ..?..

Then, the entire ac system has been deleted. (I mean everything's gone exposing hole in firewall) so those wires are staring back at me donating to my confusion lol.
The "aux blocks" (lack of proper word) that can be located on fire wall with 12v ignition etc. wire been yanked off and left behind , under the "assumed Shadiest-Shade-Tree in Shade-ville USA"
..🙄..
And also on the factory style distributor, the double clip for the outer ignition coil setup I got it in as it should be,wire clips in place ..but no clue as to the where-a-bouts' of the rest of wire
(they been cut 4in. Above the attaching white&grey/black clips and theres no obvious "suggestive" wire to choose from to tie back into as once was. My guess is gone so I'm depending on opinions here everyone.

I guess I'm asking for a basic way to simply get this situated here with what's already here, on truck.

I just want the thing to start n run without catching fire lol. Don't need be factory specs style job. Any help appreciated greatly.


There was 5 damn toggle switchs on the dash that no longer have anything at connection points on them (can only assume they must had been for "nos" or the 007 style influenced "flipping 2nd incognito liscense plates used for get aways) 🤥🤥😑😆 haha

Now I have a old cast iron intake as well as a performer Edelbrock intake and a qjet and a Edelbrock carb laying around as well as a spare hei distributor. That sounded like an easy way out but wanting to utilize wat is existing in truck just need direction to do so. Thx again in advance. Ivtryd to cover all best I know how. Sorry if confusing to you it must mean it's got the best of me 1st lol!!
 

· Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Thanks man, that was a question I had in my mind was if they made a TBI to carb adapter plate for bolting a carb onto this intake . That seems like my best bet. I'm just teetering on the decisions of useing wat is here and figuring it out and ultimately ending up with balding head lol or just install what I'm more "confident" in dealing with , thanks everyone.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top