Hot Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!
 

·
Proud LOSER
Joined
·
2,185 Posts
Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!
Any codes before you replaced the ecu? So what exactly does it do? Starts normal, put in drive, but it just won't up shift?
 

·
Administrator
Joined
·
8,551 Posts
Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!
Have the shift solenoids been checked?
Have you checked Line pressure?
Did you replace sensors with "new" ones ? Or did you put in used stuff.
AND what , if any codes were stored?
That car also has an automatic trans shift computer that is seperate from the ECU. It is in the center console.Last 99 mitsu I had with a similar shift problem needed the trans computer.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
thks for the replys ....i was wrong with the year on the eclipse its a 95 model and all sensor has been replaced.....im trying to buy this car and the owner told me everything has been replace but im not sure if the tcm has been reprogramed or not.....if it has what else do i need to check.....thks
 

·
Administrator
Joined
·
8,551 Posts
you need to find a good OBD 1 scanner that has jap software for mitsu.
Clear any codes (probably by unhooking battery, then attemp to drive it. Then scan the trans control module for codes , repair/diagnose from there

Guessing at it wont fix it.You need to get down and diagnose the issue.
Also you may want to perform a pinout test on the shift solenoids, you will need an EWD for that. Verify the signal from the TCM unit to the shift solenoids is also a must, so a solenoid state chart will be required to determine if the TCM is outputting correctly or at all.
Piece of cake.
BTW if the speedometr isnt working, that means the VSS may not be outputting, that will also cause a no upshift, most other faults will leave the trans in second gear by default.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top