Hot Rod Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
got my new used truck today, its an 85 durango S-10. I got it for real cheap cuz it quit running a few months ago. he seems to think the timing chain went out, but I just learned the distributor still spins, jumped time? perhaps but i have noticed I'm not getting spark either. so can anybody tell me how the coil works on this? its got power from ignition to one of the 4 wires that plug in the top and the reast i dont know what they are for. is there anyway to test the coil with a testlight? I dont have an extra hand around to help so some tricks would be helpfull. it cranks over allright, I dont hear any horrible noise from that.
 

·
Registered
Joined
·
7,345 Posts
ECM

Doc here:pimp:

If your coil is getting Power but you have no spark, Check the ECM for inop condition, Auto zone, Kragen or other auto superstores can test the module for you free...

Have them check several times so as to eliminate a heat problem in the car...

If it's good, then look at the magnetic pick up in the distributor.

Either of these will kill spark.

Hope it helps!

Doc :pimp:
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
hey guess what, it wasnt any of those other things killing the spark, it was, the coil. I remembered I had a engine mounted on a go-cart frame, for some chevy wagon, I took the coild off that and it plugged right into the truck, and it started right up after it un-flooded :cool: awsome, I was having second thoughts about doiung the timing chain, but no worries now, thanks :thumbup:
 

·
Registered
Joined
·
7,345 Posts
.......

Doc here:pimp:

uhhhh...OK....

Well good luck with it anyway..

Doc :pimp:
 
1 - 4 of 4 Posts
Top