Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter · #1 ·
I have a 2002 Chevy Pick-up, 2500 6.0 with a 4l80e that shifts hard after about 6-10 miles of freeway driving. The vehicle has a factory transmission temperature gauge and it reads around 125 degrees most of the time. It has been doing this for a 6 months and it does not seem to be heat related summer/winter driving all the same. It will shift hard (especially 1 to 2) until you shut the vehicle off for 30 seconds and then it immediately shifts fine around town until you go back on the freeway for around 15-20 miles of driving. If you shut if off then turn it right back on it will still shift hard, I have to shut the vehicle off, wait at least 30 seconds before it will shift normal. It takes longer the second time during the same day for it to start shifting hard. The first time around 6-10 miles, then the second time it takes 15-20 miles to start shifting hard of freeway use. The check engine light is not on and does not come on during this process.
 

·
Administrator
Joined
·
10,187 Posts
Mileage on trans?

It would nice to run a pressure check on the trans during the standard shifts and when shifts turn harsh.

Depending on mileage , I would suspect a worn boost valve or the PCS may be failing hydraulically and that will not show up on a scan tool
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top