Hot Rod Forum banner
1 - 6 of 6 Posts

·
Differential/Driveline
Joined
·
1,782 Posts
Discussion Starter · #1 ·
Using 2K Primer on a NEW 68 Camaro rear spoiler.. When I go to block sand the spoiler I've been getting 2 or 3 spots that the primer actually lifts and didnt adhere. I block sand the spoiler down and feather out the spots that lifted and spray again.

Then I'll get at least 1 spot that will lift again and in a different spot. The spots are usually 1" or 2" in Diameter. It's happened 4 or 5 times now and I'm getting stumped on this one.

Any Idea's??
 

·
Brian Martin,Freelance adviser
Joined
·
16,464 Posts
Lifting is caused by solvents getting UNDER the substrate. That spoiler must have a poor quality primer on it already. It was either poorly prepped so the primer is just "laying on top" of the spoiler so when you apply more primer over it the solvents from the new primer get under that primer because it isn't sticking well to the spoiler, and it lifts it up.

Or, the primer that is on the spoiler is 1k or poor quality 2k and when you spray your primer over it the solvents go INTO the poor quality primer because it is "soluble", lifting it.

You can strip it all off, you can spray your primer dryer so it's solvents flash off before they can be soaked up.

Sand with a finer paper feathering out these problem areas is also often a fix. If the feathering is done with a finer paper there aren't scratches that allow the solvent to get thru.

Brian
 

·
Brian Martin,Freelance adviser
Joined
·
16,464 Posts
Seldom does something need to be completely stripped, it has some problem areas and you sand those out and proceed. But if it's crappy product you are spraying over, yeah it needs to be removed.

Brian
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top