Hot Rod Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
HI guys !
Please help :)
Two years ago i bought 1979 Chevrolet Camaro Z28 with some modifications (roll cage, SBC350 with Holley Street Avenger 80670 Dual Feed, Edelbrock Performer RPM (1500-6500) intake,MSD dist., Headers, B&M TH400 trans, new sparks, cables,).

Car was in bad condition , so i start 2 years complete rebuild project (without engine).

Now car is ready , but i have problem;
Engine runs smoothly on idle (about 1000rpm) but when i put in gear it drops to 500rpm and idle rough, and dies when i turn steering wheel, but when i push gas pedal car runs and drive.
Intake is Edelbrock Performer RPM (1500-6500), i don't know what kind of camshaft is in engine, possible something performance (i saw Comp Camps Roller Rockers). Yesterday i changed carb,set ignition timing, fuel level, idle air/fuel mixture but problem is the same, tommorow i want to put Edelbrock Performer Intake ( idle-5500).
I rebuild transmission (converter is old) and i think to myself "maybe is something wrong with trans? "
What you think guys ?

thanks

Michael
Poland
 

·
Registered
Joined
·
13,467 Posts
HI guys !
Please help :)
Two years ago i bought 1979 Chevrolet Camaro Z28 with some modifications (roll cage, SBC350 with Holley Street Avenger 80670 Dual Feed, Edelbrock Performer RPM (1500-6500) intake,MSD dist., Headers, B&M TH400 trans, new sparks, cables,).

Car was in bad condition , so i start 2 years complete rebuild project (without engine).

Now car is ready , but i have problem;
Engine runs smoothly on idle (about 1000rpm) but when i put in gear it drops to 500rpm and idle rough, and dies when i turn steering wheel, but when i push gas pedal car runs and drive.
Intake is Edelbrock Performer RPM (1500-6500), i don't know what kind of camshaft is in engine, possible something performance (i saw Comp Camps Roller Rockers). Yesterday i changed carb,set ignition timing, fuel level, idle air/fuel mixture but problem is the same, tommorow i want to put Edelbrock Performer Intake ( idle-5500).
I rebuild transmission (converter is old) and i think to myself "maybe is something wrong with trans? "
What you think guys ?

thanks

Michael
Poland
You need to explore the cam timing, if it won't idle under 1000 in neutral it could be telling you it's a big stick in which case a stock converter would pull the RPMs down to low for the cam to keep the engine running. A higher stall converter would be required to allow a higher in gear idle without pulling through traffic lights when trying to be stopped. Or less cam will do the same thing.

Bogie
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top