Hot Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My turbo 350 won't reverse. It is an automatic and i can put it in reverse but it won't grab and go backwards it just rev's. All the other gears work fine but it won't reverse. I can't afford a new tranny so what should i do?
 

·
Registered
Joined
·
37 Posts
350 Tranny won't reverse

You didn't give a lot of info; when did it start, how many miles on the trans, did you check the fluid?, what have you tried? But, assuming you tried all that, try this. Put the car on jack stands and disconnect the trans linkage. With the shifter in park move the trans linkage to reverse and start the car. (Be careful)
If it has reverse the linkage needs to be adjusted, if not it may be a stuck mudulator. You may want to pull the trans pan off and check the detent lever (connected to your shifter). Make sure the nut is tight and that the linkage rod didn't come loose.
 

·
Administrator
Joined
·
10,122 Posts
70 Chevelle ss said:
My turbo 350 won't reverse. It is an automatic and i can put it in reverse but it won't grab and go backwards it just rev's. All the other gears work fine but it won't reverse. I can't afford a new tranny so what should i do?

IF the forward gears 1 - 2 - 3 work fine. the problem would seem to be the low/reverse clutch pack.

this clutch is at the rear of the case... first in , last out. Sounds like an over haul is needed.... the square cut O-ring can get hard from heat & age. They shrink , then the clutch does not work.

:cool:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top