Hot Rod Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I'm putting the final touches on my new 383 and my new tall covers don't seem to miss my roller rockers much or at least may be rubbing on the intake manifold sides. The heads are 23 deg. Strikeforce aluminum and the covers are sheet metal. They just don't seem to tilt to the inside enough or are they supposed to be this close? Pics below, Richard
 

Attachments

·
Registered
Joined
·
17,613 Posts
A miss is as good as a mile. Bolt everything up and turn it through a couple of revolutions by hand to see if you have clearance. I think you're worrying about nothing, but if there is a little interference, tap the covers with a ball peen hammer where the rockers are rubbing. No big thing.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #6 ·
techinspector1 said:
A miss is as good as a mile. Bolt everything up and turn it through a couple of revolutions by hand to see if you have clearance. I think you're worrying about nothing, but if there is a little interference, tap the covers with a ball peen hammer where the rockers are rubbing. No big thing.
A miss is as good as a mile.. I like that, when I got the block back from the machine shop I mocked it back up myself before doing the final assembly and things are close .050. I had to "convince" the covers to go on but once they were down and tight I can't feel the rockers by squeezin the cover. Just don't want any stray metal pieces in the engine when I test it. Thanks
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top