Hot Rod Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
hi i have a 96 chevy 15004wd ext cab sb with vortec 305/4l60e 188k miles, and heres the problem, when the truck is completely cold(colder outside the longer) the tranny up and dowshifts 100% beautifuly no slipping nothing its perfect for maybe 10-15 miles, then once its warmed up it completely stops shifting and stay in third unless i downshift into 2nd with shifter(been callin in powerglide mode lol) its been making it to work and home without warming up enough to stop shifting, so iv been driving it, but i would really like to have it in working order before winter hits, so if anyone know whats my problem might be thanks in advance!

p.s.
yes iv tried google.
 

·
Wrench Turner
Joined
·
4,952 Posts
Sounds like you may be loosing power to the trans causing it to go into "limp mode".Check all the wiring & connectors for loose,dirty,corroded connections.Check for power @ the trans plug.
 

·
Super Moderator
Joined
·
18,376 Posts
Is the engine light on?..Getting slippage code?

I would change the fluid and filter and see if that helps...May just be a solenoid sticking
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
already has new fluid in filter that was first thing i tried, how can i check if solonoid is sticking? and if im checking the voltage at trans plug what should the voltage be/which wire? can i find a diagram of this somewhere? any other possible problems?
 

·
Registered
Joined
·
417 Posts
Check for codes & see if there are codes that are related to any of the solenoids. Please note there is an EPC solenoid, TCC PWM solenoid, TCC lock-up solenoid, 3-2 control solenoid, & 2 shift solenoids, and a pressure manifold inside the pan. If there is an electrical problem inside the pan, it could be causing the trans to go into fail-safe which is 3rd gear only.

Once you have driven more than 15 miles and it starts to act up, from a dead stop is it taking off in 3rd gear, or will it take off in 1st? Please do this test with the shifter in the "D" (or drive 4) position. If it is taking off in 3rd, it is either the computer is commanding fail-safe, OR you are losing power to the transmission. No power to the trans will default the unit to 3rd gear.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
yep once its warmed up it takes off in 3rd with it in D, if i put it into 2nd it will take off in 2nd but only by putting it in 2nd, sometimes if i shut the truck off say if i pump gas or something it will take off in 1st and shift but only up to 3rd then it will stay in that gear. so if its the computer commanding the fail safe i need a code reader in obd2(?) to see what the problem is? if im losing power to the trans could that be a bad relay or a plug or something easy? where should i begin on a pretty strapped budget for the next few weeks but hate my truck in this fail safe mode:smash:
 

·
Registered
Joined
·
417 Posts
Start first by scanning the vehicle for transmission codes. If you don't have a code reader, go to your local Auto Zone (other parts houses do this too) and they will scan it for you for free. You need to let us know what the P codes are-example; P1800. From there, we can figure out what is happening.

Please note that 1996 model year trucks were KNOWN for having faulty ignition switches that will cause power loss to the transmission intermittently, and default the unit to 3rd gear only.

If you pull codes and there are fault codes stored for every solenoid inside the transmission then you know you have a power supply issue. If you only have a code for a single solenoid, then you have a faulty solenoid and the computer is then commanding fail-safe.

Let us know what you find with the scan.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
Please note that 1996 model year trucks were KNOWN for having faulty ignition switches that will cause power loss to the transmission intermittently
yup it sure did! TRNW Store: Transmission Power Relay System this gave me the idea how to fix it, built this basicly, except i got a relay and wires at napa and didnt buy this for 80 bucks i think i spent 20 bucks at napa. trannys been shifting sweet i feel like im in truck heaven again, now the the trucks going to get some more loving thanks
Kawabuggy!
:thumbup:
 

·
Registered
Joined
·
417 Posts
Happy to hear you got it figured out. Nothing better than driving a vehicle that first time after a repair and everything works as it should. Puts a dirt-eating grin on my face from ear to ear.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top