Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hello all new to hotrodders,
i own a 62 galaxie sedan, it has a 292 w/fordomatic i've found a 302 w/c4 transmission to put in the car i found the transmission mount that i need. but no such luck with the motor mount, i dont know what i need i'd like one with no or little mod needed to the mount. the 302 is out of a 76 F100 if that helps
thanks for looking
-jason
 

·
Registered
Joined
·
15,340 Posts
Fitts07 said:
hello all new to hotrodders,
i own a 62 galaxie sedan, it has a 292 w/fordomatic i've found a 302 w/c4 transmission to put in the car i found the transmission mount that i need. but no such luck with the motor mount, i dont know what i need i'd like one with no or little mod needed to the mount. the 302 is out of a 76 F100 if that helps
thanks for looking
-jason
Look at the 63 and 64 model, this is basically the same frame as the 62. These came with the 260 in 1963 and the 289 in 1964.

Bogie
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
i did think about that but i read somewhere that engine mounts changed after 65, my engine is a 76, do you think that i could get 289 engine mounts from a 64 and they would bolt up to my motor?
 

·
Troll Hunter
Joined
·
2,694 Posts
Engine mounts changed regularly depending on WHAT style body it was in. The engine bosses are in the same spot, it was the below the insulator that varies. As suggested front mounts from a '63-64 galaxie with a 289 will allow you to set the engine right in. Depending on the style crossmember you may not need to change anything on that end, you might have to as well ,but I have done this swap at least a half a dozen times...pretty straight forward.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top