Hot Rod Forum banner
1 - 9 of 9 Posts

·
1965 Impala SS Convertible
Joined
·
330 Posts
Discussion Starter · #1 ·
Hey everyone.I was driving my Impala last night and I noticed that my Headlights and my dash lights were really dim and looked like there wasnt much power getting to them.So the more I drove the car,the more dim the headlights got and the car allmost died before I got it home.So I figured that the alternator was bad.Well I bought a new alternator from the auto store today and put it in.I jump started the Impala and the headlights are still dim and so are the dash lights.Tha car seems like it is gonna die out everytime I drive it.Could it be that battery?I just replaced the battery about 5 monthes ago.I paid $80.00 for the battery and it is allmost brand new.So I dont know what the problem is but if anyone does,please respond.Thanks,

Eazy
 

·
Registered
Joined
·
169 Posts
Next time charge the battery instead of jumping it. It's pretty hard on the altenator to recharge an almost dead battery. You may have cooked the altenator by doing this.

Have you put a volt meter on the car? Are you getting 12V with the engine off? Is there a difference in voltage when the car is running? If there isn't a difference, the altenator is not working or at least not charging, check to make sure you hooked it up right and the engine grounds are good. If you did, the altenator is most likely a dud.

If there is a difference there should be about 13.7V when the altenator is running. You should then check the electrical system for bad grounds and bad connections in general.
 

·
Registered
Joined
·
7,345 Posts
Regulator

Doc here :pimp:

I agree with Jim, The regulator is probably bad.

Do you get a Charge light when you first turn the key on? If the lamp is blown on SOME systems You won't charge. So you might want to check that too.

Doc :pimp:
 

·
1965 Impala SS Convertible
Joined
·
330 Posts
Discussion Starter · #5 ·
65 Impala Voltage Regulator Question

Well I replaced the Alternator and the car still ran out of juice after I charged it.So now I am figuring that it is the Voltage Regulator.Does anybody know where the voltage regulator is located at on my 65 Impala?Thanks,

Eazy
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top