Hot Rod Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 ·
So we were doing some cookies in a parking lot and came out of there onto the road, I gun it and hit some loose gravel. Car spins and hops the curb perpindicular to the road, high centered just in front of the rear wheels. The car rides 3 inches off the ground, so my mufflers are messed up, and have also stopped the emergency brakes from working because they're resting on the cable. The car when on the curb would not shift, otherwise I would've just put it in reverse an got out of there. It leaked a bunch of fluid but has stopped leaking. I've got all gears except for park. It will go into park, but can't start it there and it doesn't keep the car from moving either. So park's there, but it isn't there too. Any ideas on why I have everything but park?
 

·
Administrator
Joined
·
10,122 Posts
Gladis said:
So we were doing some cookies in a parking lot and came out of there onto the road, I gun it and hit some loose gravel. Car spins and hops the curb perpindicular to the road, high centered just in front of the rear wheels. The car rides 3 inches off the ground, so my mufflers are messed up, and have also stopped the emergency brakes from working because they're resting on the cable. The car when on the curb would not shift, otherwise I would've just put it in reverse an got out of there. It leaked a bunch of fluid but has stopped leaking. I've got all gears except for park. It will go into park, but can't start it there and it doesn't keep the car from moving either. So park's there, but it isn't there too. Any ideas on why I have everything but park?

sounds like you have damaged the shifter linkage and/or the tranny it's self. I would suggest a good inspection of the under side of the car for repairs and safety issues.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top