Hot Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My wife drives this blazer in the winter to keep her nice car in good shape. All last winter I questioned if it was going into od, didnt seem so. She has a 25 mi commute so I wasnt all that woried about it. Well this morning motor died @ a light so she selected park to start, shifted into D & got nothing. All this trans will do is reverse. Fluid is @ proper level, havnt checked pressure yet. Is there a band adj. on this trans ? I know the tv cable is kinda hooked up micky mouse,(prior owner) but may still be in spec. Any help here guys would be great. Thanks---Proflow
 

·
Administrator
Joined
·
9,765 Posts
proflow said:
My wife drives this blazer in the winter to keep her nice car in good shape. All last winter I questioned if it was going into od, didnt seem so. She has a 25 mi commute so I wasnt all that woried about it. Well this morning motor died @ a light so she selected park to start, shifted into D & got nothing. All this trans will do is reverse. Fluid is @ proper level, havnt checked pressure yet. Is there a band adj. on this trans ? I know the tv cable is kinda hooked up micky mouse,(prior owner) but may still be in spec. Any help here guys would be great. Thanks---Proflow
band has nothing to do with the trans moving forward from a stop.

the truck moves only in "R" ? No movement in OD , D , 2 or 1 ??

history of the trans?

Mileage. ever rebuilt ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
s-10 trans

OK , got some more info from my wife. It almost sounds as though somethings up w/the linkage. She says the selector just floats up & down. I wont have time till tomorrow pm to check it though. When I put a new engine in it last year it looked like someone had just gone through the trans . I only say that because the tc was like brand new.I'll post back after digging into it more, thanks---Proflow
 
1 - 3 of 3 Posts
Top