Hot Rod Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
Hope you guys could help me out...

I have a 94 isuzu pickup with carbed 2.3l engine... The problem is after the engine starts, all of the lights stay on. Meaning the brake, alt, seat belt, the light test before the engine starts and the a/c does not come on. I have to rev it to about 3000 rpm, then the a/c comes on and the lights go away.

My dad had taken the alternator to advance auto to have it checked out and they say there is nothing wrong with it. Yet none of the acc. work until it's rev'd so high.

What do you guys think it might be? Maybe a relay in the alternator(just guessing) or something that makes the switch from battery to alt....

Thanks in advance...
 

·
Registered
Joined
·
128 Posts
94 Isuzu Altenator issue

Well Im not Joe Isuzu ? But if I had too guess . Im thinkin fast Idle solenoid is shorted out . << Provided it's so Equipped . << Just an educated Guess ? Due in part that AC doesnt come on until rev'ed High . But then again if AC was recently charged . Might be over Charged and or the AC clutch is Burnin out ? Just guessin . But I would look in a manual See what test can be performed on fast Idle Solenoid on the carb see what it's doin . But then Like I said Im not Joe Isuzu . Sean
 

·
Registered
Joined
·
112 Posts
Discussion Starter #3
Thanks,

But what confuses me is that it will continue to run off of the battery until the engine is rev'd. I mean the headlight, radio, all of the acc's. Now once the engine is rev'd pasted 3000 rpm, it's like i the alternator takes over and it runs like it's suppose to.....

Not sure if I got a bad alternator...

Any other ideas....
 

·
Registered
Joined
·
7,396 Posts
check for field current to the alternator, if it's externally regulated, it will have a small wire coming off it, that will be the wire you check for power at, you could also hold a screwdriver to the back of the alt and check for magnatism, if you do not get power/ magnatism the alt is not the problem, you then need to back trace to the regulator and make shure it's working.

your alt could be causing the problem because the alt light gets power from 2 sides, the light stays off ( the 2 sides fight eachother and nothing happens ) but if 1 side of the circut breaks, power can then feed the light as current can flow, could be wired into the other dummy lights making them all stay on, as all the lights operate on the same principal as the alt light, 2 sides of current= no flow, but if there other side of the circut is the alt, than theres why they stay on.
 
1 - 4 of 4 Posts
Top