Hot Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter · #1 ·
94 LT1 out of roadmaster.
Painless kit installed by a shop.
Truck was there a year, had to bring it home unfinished.
Now we have it back together.
Both 29 and 30 pins off the computer, I have read, are the data to the reader.
connected them to both to obd1 and 2 and don’t get a code.

engine is running rough and check engine light is on. It stalls out and backfires.
Fuel pressure at 40, replaced temp sensor, map and maf, plugs and injectors.

many ideas?
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #4 ·
Update;
The driver’s side knock sensor was not connected to the circuit properly, it is now fixed.

check engine light is off!

no more dark smoke, but it is backfiring and rough idle to even dying.

many ideas?
 

·
Administrator
Joined
·
8,477 Posts
GM service manual says you should be able to get flash codes.
Are you sure you have the correct wires jumped for blink codes?
You should have a white with black tracer pin D20 at PCM = field test mode enable
and the ground side will be Black with white tracer at the aldl.
I know you said you have a painless wiring so you will have to verify the field test mode enable circuit from the PCM pin D20 . Ground the wire and you should get flash/blink codes.If not the PCM may be wacked

Pin D29 at the pcm is serial data. Not sure what you meant about pin 29 and pin 30 as you have multiple connectors on that unit and each has multiple rows of pins.So verifying the correct pinout is necessary
 
1 - 6 of 6 Posts
Top