Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,056 Posts
Discussion Starter · #1 ·
This post is for all the Chrysler service techs. I just started putting new plugs and wires with cap on my wifes 98 sebering conv.with 2.5 v/6. I feel for you guys that have to work on this crap designed junk everyday. If i could just get my hands on the guy that designed this thing in a dark alley for ten minutes my knuckles would be even more banged up than they are now.I've never seen anything like this peice of junk in my life. Can't even see half the bolts let alone get them out.You have to take the whole top off the motor just to get at the back three plugs. Now how dumb is that.
 

·
Banned
Joined
·
6 Posts
Iy is also GM. I went through the same thing on my son's 98 Grand-Am v6. I also had to remove coil packs and a bunch of other stuff just to get a the back 3 plugs. Thank God the plugs last at least 100,000 miles These will be the last plugs that will be needed.
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter · #3 ·
Well finally got new plugs, cap, plug wires and rotor in. Thing runs good but still has code on computor. Does anyone know how to remove this? Is it like older system where you just onhook batt cable for a while?
 

·
Banned
Joined
·
6 Posts
swvalcon said:
Well finally got new plugs, cap, plug wires and rotor in. Thing runs good but still has code on computor. Does anyone know how to remove this? Is it like older system where you just onhook batt cable for a while?
Yes unhook the battery for at least 5 minutes and try starting the car with the battery dicconnected, cycle the key 3 times and that should clear all codes.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top