Hot Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I am having ignition troubles for a 73 Vette. I have replaced the points with a Crane Cams XR-i module. Currently, the engine turns over strongly but I am not getting any spark. Further, I am getting only 9V at the starter and at the coil when turning the key to start, and a full 12V when the key is in the run position. The ignition switch is brand new and seems to be operating correctly. Finally, I know the XR-i module works because I can start the engine just fine when using a 12V spliced lead to the coil and one to the starter. Am I missing something fundamental here?
Thanks for any help you can give.
 

·
Registered
Joined
·
529 Posts
Sounds like your "Run" wire is going through a resister before the distributor/coil. The "start" wire comes off the starter solenoid.
Points ignitions worked on a reduced voltage, but started with full 12 volts.
Try running a separate, new wire from the ignition swith to the distributor/coil. That should give you the 12 volts needed to run.
JA
 

·
Registered
Joined
·
7,345 Posts
Doc here, :pimp:

Check your Crane instructions, see if they require the ballast to protect the module..

If not, remove it, or the resistance wire (it should be marked as such) and test again.

As A test, jump the coil + direct to the battery, see if it will start and run, If so you need to find the resistor or wire and remove it. (you'll need to remove the jumper to stop the engine)

If it Won't start, suspect the module or coil..test both.

Coil:

DVOM, set to OHMS, R X 1, Calibrated to 000.

Primary= less than an ohm, but more than "000" to be good.

Secondary=10,000 to 11,000 (for any remote type coil) and 6,000 to 30,000 for stock type GM in Cap Type.

The module MAY or may not be able to be tested at auto zombie for free..because it is crane..so you may just need a new one to tell..

If it's still not sparking, check the magnetic or optic pickup, depending on what crane uses.

Doc :pimp:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top