Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a standard Chevy 350 with a 4 barrel carb in my 81 Corvette. Total miles about 87K. The carb and associated components have worked fine, kept clean never needed service. Car is garaged. Problem: Once the elctronic choke opens up, the engine rpm drops to a lower value as usual. When I tap the accelerator to drop it further down to normal rpm, the engine quits as the choke light illuminates. I recently replaced the fuel pump and fuel pressure output from the pump appears normal. Thanks for your suggestions. Cp
 

·
Banned
Joined
·
1,971 Posts
turn the idle screw up on driverside of the carb


make sure pcv valve is open and not clogged shake it see if it rattles

if not replace it

make sure egr valve is closed completely at idle and loer rpm also it will kill the idle and the engine if its open at low rpm

new cap wires plugs would be good idea if they are old


also make sure carb mounting bolts are tight

also try running the engine up around 500 rpm or so by hand at the carb linkage and slap the choke flap shut for a couple seconds then let go of the choke flap and let the engine catch back up again to suck crap out of the carb it will idle faster and better after this

do it after sitting a while being stored

needs to be done now and then

sucks the jets clean etc

car is sitting too much it needs to be driven or things like this will happen especially on a carb vehicle

eventually its gonna need a carb rebuild or new carb

carbs cant take sitting dry alot like this without going bad

seals and gaskets dry up in them

acclerator pump will quit sealing and working

and so on

drive it more, sell it, or trade it or it wil always nickle and dime ya and have issues like this





have fun
 

·
Registered
Joined
·
34 Posts
ckpena said:
I have a standard Chevy 350 with a 4 barrel carb in my 81 Corvette. Total miles about 87K. The carb and associated components have worked fine, kept clean never needed service. Car is garaged. Problem: Once the elctronic choke opens up, the engine rpm drops to a lower value as usual. When I tap the accelerator to drop it further down to normal rpm, the engine quits as the choke light illuminates. I recently replaced the fuel pump and fuel pressure output from the pump appears normal. Thanks for your suggestions. Cp
Also check for vacuum leaks. With the choke closed, the mixture of fuel/air is enrichened.

Once the choke opens, it might be throwing your mixture out of wack...e.g. a vacuum leak allowing unmetered fresh air into the combustion chambers...
 

·
Certifiable Streetrodder
Joined
·
371 Posts
I had the exact issue on my son's z28, only to find that the primary throttle shafts were so worn that you could grasp them and actually move them up and down, causing a vacuum leak that caused the engine to run o.k. until the choke opened, then the engine would not idle but slowly lose r.p.m.'s until it would die! I replaced the carb with a friends carbshop quadrajet, and the problem was solved completely! I ordered a bushing kit from jet performance that comes with the proper drill and reamer to fix the problem. quadrajets are notorious for primary throttle shaft wear. :pimp:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top