Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a standard Chevy 350 with a 4 barrel carb in my 81 Corvette. Total miles about 87K. The carb and associated components have worked fine, kept clean never needed service. Car is garaged. Problem: Once the electronic choke opens up, the engine rpm drops to a lower value as usual. When I tap the accelerator to drop it further down to normal rpm, the engine quits as the choke light illuminates. I recently replaced the fuel pump and fuel pressure output from the pump appears normal. Thanks for your suggestions. Cp
 

·
elkyholic
Joined
·
327 Posts
Remove your air cleaner lid and verify that the choke released (opened). I think that the first drop in rpm is your ECM, then when you tap the throttle and the choke doesn't release your engine goes rich and stalls.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Yes, occasionally the problem would occur but was always solved by giving a little gas and ultimately normal idle would be restored. Not the case now. I'm in Europe on business and will not be home for a bit. When I get back, I'll remove the air cleaner and check. I think you are right, the choke is not opening so the fuel flow is going full rich. If this is the case, what's the cure? Thanks again. I appreciate your time. Cp
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top