Hot Rod Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I couldnt get the crane system to ever send a signal to the coil. I tried everything i could think of, or read to do. Ran with and without ballast resistance, tried new coil, finally put new points on and it fired. I called crane and was advised that this particluar rep hadnt had any modules fail, but it was ofcourse possible. Just curious if you guys have heard of the module being bad? I always tend to think that I have done something wrong (which is usually the case) but after hooking up points and it fired, thinking i should send unit back for an exchange.......... whatchathink? (69 ford galaxie w/ warmed 390)
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
A 6 volt coiL?? I used an aftermarket 12 volt from jegs-------the instructions only mentioned needing the ballast resistor, which i did use- however upon start a solid 12 volts is sent around the resistor wire------------- also noticed that the module reads that operating voltage is 8-18 volts. ? Will smell the thing tonight:pain:
 

·
Registered
Joined
·
7,345 Posts
Doc here, :pimp:

Go here:

http://www.cranecams.com/pdf/90001700b.pdf

It's crane's Website..This is where you can read the troubleshoot for the XR~I ignition system..

Long story short...

The coil must be 12 volts..You must run a Ballast resistor (unlike stock it goes to two places..refer to the drawing..)

The voltage at the output side of the ballast, must not be less than 9 volts (loaded) and Must maintain that through crank...

You may have some secondary Ignition issues, check the "I" terminal of the Solenoid and be sure it's still hooked up..this supports power through Cranking mode...

Yes, ANY (and EVERY) Module has VERY high failure rates right out of the box...Like 1 in 3....QC is not a Buzz word in Mexico or China...I always advocate checking (even a stock module) before you leave the store..(you'll see quickly how abysmal the fail rate is on these if you do..)

Go to the site , Verify hookup, verify Voltages, and if it checks good suspect the module.

Doc :pimp:
 

·
Fishing poles in the hot rod!
Joined
·
109 Posts
I have a resistance wire instead of a ballast resistor. Does should I hook the module up to this resistance wire or should I hook it to a regular wire off the ignition? It seems like from the Crane diagram it shows the module connected before the ballast resistor, which would give it a full 12 volts, correct? Thanks, all.
 

·
Registered
Joined
·
7,345 Posts
FiveFeezy said:
I have a resistance wire instead of a ballast resistor. Does should I hook the module up to this resistance wire or should I hook it to a regular wire off the ignition? It seems like from the Crane diagram it shows the module connected before the ballast resistor, which would give it a full 12 volts, correct? Thanks, all.
Doc here, :pimp:

According to Cranes drawing, your Constant 12 volts ("Hot in Run") to the Coil + from the "Ignition" side of the key will be through the resistor wire..which will give it 9 volts at the coil + side...

The Secondary Ignition, (or "I" from the solenoid, or power from the key in "Start") will go to the same side of the ballast as the Resistor/resistor wire.Or directly to the + side of the coil, and provide 12 volts during Cranking modes.

The Module wire (Bk / Red) wire will go to the input (or 12 volts side of the resistor..or in your case with a resistor wire..the "Hot In Run" position of the key, or any "switched power") The module will receive a full 12 volts, the coil (loaded) will get 9 volts during normal running mode.

Doc :pimp:
 

·
Banned
Joined
·
103 Posts
I am in the specialty, custom ignition system business, and have removed just over 150 of the XRi drop ins. This is significantly less than the PerTronix Ignitors I have removed over the years.

Almost every Crane removed had rev limiter issues. Crane wouldn't warrantee any of them.

There are better ways to trigger an MSD type box than another drop in complete ignition system.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top