Hot Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 · (Edited)
On or about May 2004 I installed this kit in 350 sbc. Sept 05
motor started skipping. It turned out #8 ext valve out of adjustment, the lifter grew,retainer came off (somewhere in motor).Removed int manifold repaired lifter w/horseshoe type retainer. (all kit lifters come with stamped type retalners). Dec
15-06 I started chaning valve springs on 2 4 6 & 8. started on
1 and when I replaced the push rods I noticed the int. rod was not the same height as the ext. :mad: I said to my self I've got a problem. I finish changing 3 5 & 7 springs (changed retainers & locks). :sweat: I removed air cond. compressor,bracket ,alt, & int manifold. I found (4 , fore) more lifters that had come apart,lifter seats laying in oil valey
Stamp retainers on 3 more were cracked :sweat: If this motor has ever seen 5000 some body else was turning it. The Edelbrock tech said "all 7102 kits were high reving" I guess that means this cam kit is not for around town & kruzzing :welcome: My question: Has anybody out there had
problems as such. I don't think "old jim dandy " will buy any more Edelbrock internal parts. :thumbup: :thumbup: Web site.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #2 · (Edited)
EDL 7102 cam kit woes

Since stated I'm a little teeed off about edelbrock products, I intend to install "doug herbert" lifters. part #HERT817. :drool: Question: do I kneed to do anything beside use cam lube @ fire it up, do I need run motor to break in lifters, or what? :confused: This is first time changing lifters. w\out changing cam too. Any @ all input will
be.apreaciated. :welcome: :welcome: As always "hotrodders
wed site " is :thumbup: :thumbup:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top