Hot Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
Hi

I have been to a car meet all weekend and it was great. we where out cruising over a 100 cars, we did alot of burnouts and generally just fooled around and had a good time.

But anyways on the way home i did a huge burnout, and I think that I may have over reved the engine:drunk: because a little later it stated knocking from about 1500 rpm and up oil press is still fine and at idle it sounds fine. I have torn out the engine and is going to open it up today. I don't think that it is a rod bearing going bad it didn't sound like that, I was think more like a bent valve hitting the piston or something like that.

The knocking sound is sounds like it is coming from number 6 or 8 cylinder. I toke a peek under the valve cover on the passenger side and everything looks fine.

Ohh btw. the engine is a 454 bored 30 over I don't know about the cam other than it is not stock but not too aggressive either.

What do you guys think?

Sune
 

·
Premium Member
Joined
·
2,370 Posts
I dont see how the pistion could be hitting the valve. Even partially bent it shouldn't be dipped that low. Is it running adverse (other than the sound)? If you had a valve bent you'd be getting some popping and would definitely feel and hear it at idle. Perhaps you have some timing chain slack? Take a look at the valve train. First determine if its top or bottom end. Just work through it all.

I am sure someone much more knowledgeable will chime in here soon.
 

·
Registered
Joined
·
358 Posts
that would be my guess as well, maybe a broken or backed off rocker arm? Easier to pop off a valve cover than pull the engine.
 

·
Pure American Muscle
Joined
·
684 Posts
Agreed I had that happen to me. I was having trouble with my rocker arms and one got to tight and I went up a hill with 2 people in the back and BAM knocking noise. If I set at idle it sounds ok and ran fine but don't step on it cause man o man sounded like things were falling apart. Take the covers off and look for a pushrod that is just kinda sitting there lol mine blew a hole right through the rocker arm. Good luck!
 

·
Registered
Joined
·
85 Posts
Discussion Starter #5
well i opened it up

All the bearings are trash..!! :mad: the rod bearings are really bad, the mains not that bad.... it looks like the idiot that rebuild it before I got it just threw some new bearings after it and didn't bother to clean it up!!!

I just can't figure out why I still had good oil pressure??

or well now I have an excuse to get one of those +0.25 stroker kits... those will fit in a standard four bolt block right?

sune
 

·
Pure American Muscle
Joined
·
684 Posts
Yicks!
Sorry to hear about your loss. Tough I would say that it could have been much worse trashing a block or really destroying something. For those kits I would think they should say what they will fit. Good luck!
 

·
Registered
Joined
·
85 Posts
Discussion Starter #7
strikingthematch said:
Yicks!
Sorry to hear about your loss. Tough I would say that it could have been much worse trashing a block or really destroying something. For those kits I would think they should say what they will fit. Good luck!
Yeah I'm glad I caught it in time, none of the mains had spun. only some of the rod bearings.

sune
 
1 - 7 of 7 Posts
Top