Hot Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
My 84 camaro seems to have a large amount of exhaust when i start the car.. someone mentioned to me that it could be some sort of leak. Should i do something about this? Also my idle speed seems really low. I have automatic overdrive, so its usually low but when i come to a stop it seems to sound like its chugging. It just a rough sound. Then when I accelerate I get this wierd smell I cant really describe it but i was wondering if the two had anything in common? Im not sure what the smell is from but it has just happened recently so its a little strange to me. When i open the door it gets stronger.. there is no smoke under the hood though.. so i have no idea. Any input would be appreciated
 

·
Registered
Joined
·
159 Posts
eM-K said:
My 84 camaro seems to have a large amount of exhaust when i start the car.. someone mentioned to me that it could be some sort of leak. Should i do something about this? Also my idle speed seems really low. I have automatic overdrive, so its usually low but when i come to a stop it seems to sound like its chugging. It just a rough sound. Then when I accelerate I get this wierd smell I cant really describe it but i was wondering if the two had anything in common? Im not sure what the smell is from but it has just happened recently so its a little strange to me. When i open the door it gets stronger.. there is no smoke under the hood though.. so i have no idea. Any input would be appreciated
check iff all cylinders are fireing,, iff you have 1 bad spark plug she will icle lower than normal and cause the chugg.. work thru the elimitation process,,..
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
eM-K said:
My 84 camaro seems to have a large amount of exhaust when i start the car..
__________________________________________________
tc
I'm not sure just what you mean. More exhaust or less exhaust, how do you measure it? Do you mean smoke?
__________________________________________________

someone mentioned to me that it could be some sort of leak. Should i do something about this?
__________________________________________________
tc
If it is smoke you are referring to, it is passable they were referring to leaky valve seals. If thats what it causing it, then it should be fixed.
__________________________________________________

Also my idle speed seems really low. I have automatic overdrive, so its usually low but when i come to a stop it seems to sound like its chugging. It just a rough sound.
__________________________________________________
tc
Maybe you need to adjust the ol carb. Also the plugs could be loading up with oil from the leaking valve guides.
__________________________________________________

Then when I accelerate I get this wierd smell I cant really describe it but i was wondering if the two had anything in common? Im not sure what the smell is from but it has just happened recently so its a little strange to me. When i open the door it gets stronger.. there is no smoke under the hood though.. so i have no idea. Any input would be appreciated

If your smelling the exhaust, you must have an exhaust leak, very dangerous, Get it fixed ASAP.

:sweat: :sweat:

Troy
 
1 - 3 of 3 Posts
Top