Hot Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 1973 Nova 350 with 2004-r transmission surges when cold in first and second gear but once it warms up it drives like a raped ape, but that really screws winter driveability when i need to get to school what is causing this?
 

·
Registered
Joined
·
3,441 Posts
An engine needs a much richer mixture when it is cold. You most likely just need to run with the choke partially pulled for about 5 minutes while the engine warms up. If it is electric choke, then it is likely not working.

Chris
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Its not the choke

Its not the choke...its like it wants to run but it backfires and wants to run again but backfires agian its like a cycle i think it might be the timing or somthin wut yall think?
 

·
Registered
Joined
·
18 Posts
check in this order

choke, timing, fuel pump

drivabilty isnt fun....start w/ one piece at a time
till it runs good

let us know how it goes

R.

ive been trying to get my carb jetted right for weeks
its trial and error......w/ 20+ year old cars

there is no comperter to tell you what is wrong
:smash:
 

·
Registered
Joined
·
3,441 Posts
Re: Its not the choke

Nova Does Go said:
Its not the choke...its like it wants to run but it backfires and wants to run again but backfires agian its like a cycle i think it might be the timing or somthin wut yall think?
Why did you ask if you already know.....or maybe you dont!

Lean pop or lean backfire......do a search.
 
1 - 6 of 6 Posts
Top