Hot Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter #1
I just got a 1976 Ford F100 with inline-6 motor which needs a bit of a tune-up. Can anyone help me with these specs please?
 

·
Registered
Joined
·
2,288 Posts
I'm in the process of moving, so all of my books are packed away right now. But if no one else has come along and replied, i'll dig a book out when I get home tonight.:thumbup:
 

·
Registered
Joined
·
261 Posts
Discussion Starter #3
Thanks Larry.

I'd appreciate it.

I noticed that it's temp gauge doesn't work but when looking around on the motor I couldn't find where the sender is located.
 

·
Registered
Joined
·
806 Posts
here we go

Spark plug gap .044 Electronic Ignition


I dunno if this helps at all but it says the origonal plugs were BRF-42B

The rest of the stuff it says see underhood specification sticker :smash:
 

·
Registered
Joined
·
1,205 Posts
Look under the manifold toward the rear of the engine for the temp sender. Base timing is around 6-8. Factory specs are just a guideline on any vehicle this old simce gasoline formulation is nothing like it was then. My 72 300-6 is real finnicky about the timing. Factory spec is 8 but it pings on 8. Set it back to 4 and it has a noticable loss of power. It has to be 6 degrees advance with very little tolerance.
 

·
Registered
Joined
·
261 Posts
Discussion Starter #7
Any chance any of you know the valve clearance specs? They sound slightly noisy so I just want to go over it to make sure.
 
1 - 7 of 7 Posts
Top