Hot Rod Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
Took my 87 Caprice to get inspected today. Thought everything was gonna be good.
The guy comes out says I failed because of my front suspension. I asked him what was wrong with it and all he would tell me is that the tires wiggled when he had it on the lift.

So I went home and jacked it up for myself. The tires did wiggle from left to right.
What part of the suspension is going bad. Any ideas?
I was thinking tirods, but im not sure
thanks
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
You need a buddy to watch while you shake the wheels or the steering wheel. It could just be the wheel bearings need tightened. Check the idler arm, the pitman arm, cross link, tie rod ends and the ball joints.

Troy
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
Just look under it. If there is any slack you should be able to see it.

Troy
 

·
Too many hobbies!
Joined
·
239 Posts
On your caprice, I'd bet on the idler arm. That has always been the weak link in that style setup.
While you're under there, check up the tie rod ends for play, and as mentioned, make sure the gearbox isn't too sloppy.

Good luck on your next attempt.:thumbup:
 

·
Come Home Safe Soldier
Joined
·
846 Posts
Another place to look is the rag joint.The one on my 85 ElCamino was the culprit in my shake.
 

·
Come Home Safe Soldier
Joined
·
846 Posts
It is in the steering shaft,under the hood,a few inches above the input shaft on your steering box.It is a layered rubber disc that connects the two parts of the shaft togather.Over time the fabric and rubber begin to deteriorate and lead to slop in the steering.
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
troy-curt said:
Just look under it. If there is any slack you should be able to see it.

Troy
Read all the posts.

Troy
 
1 - 11 of 11 Posts
Top