Hot Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hi I have an '86 Camaro IROC-Z, it was carburated when i bought it but I recently converted it to a TPI system, and along with it came a new fuel tank made specially for the system because of it's reservoir which is supposed to prevent the fuel pump from running dry when the car is swaying the fuel back and forth, anyway mine is not doing so, for some reason when my tank goes below a 1/4 tank, (half tank in big corners) it hesitates and feels as if it's going to stall but then kicks back again as soon as the car straightens out, i've had the tank rechecked and rechecked by my mechanic and the place it came from and it's the right tank, i've also asked everybody I know about my conundrum but i'm still stumped, any kind of knowledge on the subject would be much appreciated! :) thanks
 

·
Registered
Joined
·
977 Posts
I have a pick up that would run with a miss and would not restart if shut off if less than 5 gallons was in the tank. I thought that the sock must have fell off the pump. Dropped the tank, sock was in place. Replaced the fuel pump and never had another problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
when the TPI conversion was done I used a brand new pump, and a GM pump rather than aftermarket as I've been told they last longer, so I'm not sure replacing it would do a lot of good, but then again even new things can go wrong......still stumped
 

·
Premium Member
Joined
·
2,370 Posts
So they have verified that the pump is sitting low enough so that its pickup is in the valley at the bottom of the tank? Perhaps you have a clog or holdup in your system enough so that when the pump has to "work" harder to pull gas, it hesitates. Just some ideas but I'd check the pickup, filter, pulsator, pump sock etc. Whats your fuel pressure set at?
 

·
a red wool sock on his dinger
Joined
·
238 Posts
Sounds like there isn't a tall enough
baffle around the sump, so the fuel is
sloshing away from the pick up... don't
know what else would cause this...
 
1 - 5 of 5 Posts
Top