Hot Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
i'm not really sure how to ask my question so i'll just describe my situation,
(67 chevy p/u 350eng with 600 edelbrock carb stock feul pump) when i'm launching my truck at strip, it has started to stumble something awful! as if it was loading up. but there is no black smoke coming through the exhaust. but as soon as i let off the gas it idle just fine. i can even get a few good revs in. so when i put it back in gear and try to launch again. it does the same thing! stumbles or bogg! as if to just cut off! i've checked all of my hoses and in line joints for lose or broken places. found nothing and smell no gas. i have a glass feul filter, so when i checked it, i noticed that it was only half full with the engine running. while watching the filter i gave it a few revs to see if the filter will fill up. well, it didn't. finaly, when i'm on a long stretch ( hwy) i notice that every now and then (at hwy speed) it feels like i am driving into some very high winds. then it goes away. feels like i'm being slowed down for some reason. like the wind pushing against me. then it stops !!i have replaced the fuel pump and it still does it. the filter is clean. no lines are to close to any heat sorce. fuel tank is original with out return line. is it possible that i'm not getting enough gas to the carb to fuel a launch and hold steady hwy speeds? is this what they call "VAPOR LOCK" ? any helpful tips and suggestions will be appreciated.
thanks
 

·
Registered
Joined
·
676 Posts
HEY SLOW:

I had a similar problem on my 350 SBC with a Quadrajet. I was using those glass filters and when I would accelerate it would act like it was missing out. I took them out, cleaned them up and within a week I had same problem. I ended up having to drain gas tank and go with real filters and it solved the problem. My problem was caused by the guy who built car left gas tank open during construction so it picked up a lot of dirt and rust. Sometimes it is the simple simple things, you might try pumping some gas into a clean glass container and see if there is any contaminates..GOOD LUCK...DAVE
 
1 - 3 of 3 Posts
Top