Hot Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
I hope I am welcome here...im 24 not much of a hotrodder...got shafted with a v6 camaro about 6 years ago looks really good but missing the most important part of the Camaro th v8 anyway...totalled it tackeled the job of installing another engine...debated with the ls1 long story short..used the LS1 money to buy a 1990 4x4 chevy silverado 350sb 5.7l...been messing with this damn transmission leak for months been on all kinds of forums but cant seem to get much help...been posting on pirate4x4.com for the last week but havnt got much help on there... once agian I hope im welcome here I hope to one day swap my 3800 series II camaro for a LS1/LT1 or just get me a z28 or SS..and live happily ever after.

-Cook-
 

·
Premium Member
Joined
·
11,051 Posts
Welcome to the site.. :thumbup: Great to have you here.. :thumbup: Everyone is welcome.. As far as the can of fix it..I don't believe in a mechanic in a can.. good luck.. :thumbup:
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #5 ·
Thanks guy..im off to make a bushing driver for my front pump bushing.

Im going to try a large bolt with washers sandwiched between two nuts, ill let you all know how it turns out.
-Cook-
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #6 ·
cant find the right size washers.

I found a pipe coupler with the threads on the inside, put it on the bushing gave it a couple taps.. the bushing moved however the coupler began pressing itself into the housing, im going to polish it maybe shave it a bit with the grinder.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top