Hot Rod Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Just bought a 1980 Camaro with a 350 and I am looking to fix her up. Came here because I am having trouble with the car idle in gear. Idles fine in park but as soon as I shift into any gear she bogs down and dies unless I butterfly her for a few moments. I have changed out plugs and wires, distributor, checked the timing, and adjusted the idle all to no improvement. I've even replaced vacuum advance and all lines to it.
 

·
Registered
Joined
·
17,613 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I mean that the timing is fine. Took off carb and the diaphragm is a bit stiffer than it should be, and there was something that looked like fluffy mold in it. Going to rebuild carb this coming weekend and clean jets, change the coil and see if that doesn't clear it up.
 

·
Registered
Joined
·
67 Posts
I mean that the timing is fine. Took off carb and the diaphragm is a bit stiffer than it should be, and there was something that looked like fluffy mold in it. Going to rebuild carb this coming weekend and clean jets, change the coil and see if that doesn't clear it up.
Timing is fine...? How many degrees of initial timing does it have.:confused: Thats what we are looking for. Also a little more information about the motor would be helpful. (cam, heads, intake, etc)

Chevyguy13
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top