Hot Rod Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Everyone, My name is Michael. I'm 21 yrs old, and I live in North Carolina where I'm a Career Firefighter in a town called Browns Summit. Anything else just ask.

I have a 1992 S10 and I'v recently put a 350 in it with a 5 speed behind it. 1986 Block. The bottom end is stock with flat top pistons. I had the rotating assembly balanced and the cam I have is a Blue Racer by Crane Cam. It has 224/234 duration at .050 and .465/.488 lift, Lp is 114.It is a hydraulic flat tappet. I have the edelbrock E-tec 200 Cylinder Heads which have 2.02/1.60 valves 64cc, 200cc runners. A performer intake with a A.E.D 650 H.O. Carb, and 1.5.1 Roller Rockers, and a MSD ignition System. 10.2.1 compression.

My Question is I need some Cam help. This cam performs fine but it has little sound it sounds stock when the engine warms up. and I want a lopey cam, but I don't really want to take the heads back off to check clearance. I was wanting to know if you guys knew what to use. Judging by the numbers I thought it would lope but it doesn't. Any help would be appreciated.
 

·
Administrator
Joined
·
18,646 Posts
welcome Michael...Probably best to ask in the engine forum........

Are you running headers....I find that headers make much of the sound that we are usually looking for.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top