Hot Rod Forum banner
1 - 2 of 9 Posts

· Registered
Joined
·
243 Posts
Discussion Starter · #1 ·
If you ran the same ET at 1/4 throttle as you did at full throttle even though your rear squirters were squirtng and your throttle blades were opening {at WOT) would that mean that the rear metering block was somehow defective or maybe the incorrect one was installed? Used 700 double pumper 4778-3. The front block was marked 4778 but the rear was a 383-440 mopar number. Chrysler part # 3420374.
 

· Registered
Joined
·
243 Posts
Discussion Starter · #9 ·
You must be getting at least some fuel flow through the secondary jets or you'd have a massive bog when the secondary throttle blades are wide open, and you'd actually run faster on just the primaries. I'd soak the carb body and metering block in carb cleaner and blow out all passages for starters. Then again, maybe that Chrysler metering block is somehow not compatible with a standard 4778 carb.

On another note, has the engine run as expected in the past with another carb?
No all fresh stuff.
Not that I ever knew of, they just seem overlooked by many so not as many sold, but there weren't any problems with them. 700 and 800 get overlooked because not all companies offer those size would be my guess.
I used an original 4780-AAS, the original roller link secondary design and it was a real good carb, then sold it to a friend and he raced with it for years.
I recall an 830cfm Holley that was unpopular, it was basically the bigger 850 main body with an smaller 800 baseplate to make it 830 cfm. It seemed to have trouble with metering clean below 3500 rpm


for the Op's problem,
I'm going to go out o a limb and say there is something not compatible with that Mopar metering block.....If the picture I just googled and looked at in the Ebay listing for that exact metering block is correct (guy has the original Mopar box too, so looks legit), ...then it is the source of your problem.
There is a third circuit or something in that block, I'm not familiar with what it is but I can definitely tell you just by looking at the cast shape that the block is incorrect. It likely has altered and/or additional air bleeds and passages and their locations....so passages may not even align with the main body even though it bolts up..
It's been so long since I looked at one, it may even be a reverse idle metering block.

Also, best I can tell it is a primary metering block, and not a secondary.

View attachment 627755


You'd be $50 farther ahead to just order the correct replacement metering block for that 4778.
.
I did order a correct metering block, just haven't been back to the track yet. I also picked up a 3310-6 to try.
 
1 - 2 of 9 Posts
Top