Hot Rod Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Helping a buddy dial-in his 3 x 2 setup on his A. Got the WOT and cruise dialed in but the idle is a little lean (19.5 AFR+/-), pops and dies when cold, still lean at idle when warm. Idle mixture screws about to fall out. Headers glow when cold!!
I know what to do with a Holley but not a Rochester.


Help a bro out! :D
 

·
Administrator
Joined
·
8,211 Posts
Part number 37 is the venture cluster. Arent the 2 little tubes closest to the outer edge ,on the underside, the Idle channel restrictors?
Cant you open them up? Or ........?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Part number 37 is the venture cluster. Arent the 2 little tubes closest to the outer edge ,on the underside, the Idle channel restrictors?
Cant you open them up? Or ........?
OK so opening them up, say .005" at the time will richen up the idle?
 

·
Administrator
Joined
·
8,211 Posts
That is what I am thinking. I also agree with IMSPORT . If the upper air bleeds are downsized, it will cause more fuel to be pulled into the Idle passage .
It would stand to reason that a 2 barrel from a larger motor, say a 400, would have larger tubes and channel restrictions. Got any other carbs laying around?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
Turned out the timing was retarded and was heating up the headers red hot and allowed the A/F meter to read lean(??). The motor had one of those spun aluminum harmonic balancer covers that apparently was indexed wrong. The car had a bad flat spot just off idle, advanced the timing and the flat spot went away, lean idle went away.
 
1 - 8 of 8 Posts
Top