Hot Rod Forum banner
1 - 17 of 17 Posts

·
Tazz
Joined
·
2,048 Posts
Discussion Starter · #1 ·
My 74 Dodge PU with 98,600miles or could be198,600miles the timing jumps around with the timing light on the engine?? Won't settle down...hot or cold and only slightly when the engine reves up?? There is a bad bog upon acceleration till it warms up then it seems to accelerate better. I rebuilt the carb and installed a new accelerator pump and base gasket on the carb. What do you guys think the problem is here..like I said I have an idea but want opinions before I dig into this.


Tazz


Rat Rods Rule!
 

·
Tazz
Joined
·
2,048 Posts
Discussion Starter · #3 ·
timing chain or distributor?

That was the first thing I replaced was the distributor, didn't help a bit so I'm leaning towards the timing chain now.


Tazz


Rat Rods Rule!
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
My guess would be timing chain and gears. Check the back and forth movement at the rotor.:mwink:

Troy
 

·
Tazz
Joined
·
2,048 Posts
Discussion Starter · #6 ·
To fix the Dodge truck or not to fix the Dodge truck???

Good...I'll grab my book and do some reading and go the NAPA and pick up a set of timing gears and chain and have at it then!!!
Damn Dodge truck anyway!!


Tazz


Rat Rods Rule!
 

·
current hot rod: CTS-V
Joined
·
1,821 Posts
killerformula said:
those chains are easier to replace than the chevy chains... timing cover is better designed on the mopars without a doubt!

K
I think everyone had a better timing cover design than chevy.

Yes I have spent hours trying to put a sbc timing cover back on without droping the oil pan.:pain:
 

·
I need a bucket of arc sparks
Joined
·
895 Posts
It sounds like your timing chain, I usually check them by grabbing the harmonic balancer and move it back and forth, you will feel the slop in it and sometimes it will make a popping noise if it is bad.
 

·
Registered
Joined
·
1,418 Posts
The engine in the Gremlin was jumping around also. Timing was set great and then whamo! It would jump time again. I rebuilt the carb, dist, coil and nothing. Id guess that to. HG
 

·
Administrator
Joined
·
10,120 Posts
waynedawg said:
Whats a big block chevy guy that works at ford doing driving a dodge?:D

====== I drive an old 1961 Dodge Lancer now & then... 350 chevy motor , ford front suspension and rear diff.


I have the big 3 all covered in the car.. :thumbup:
 

·
Registered
Joined
·
2,354 Posts
Tazz, the last time I had this problem, it turned out to be a harmonic balancer that was about to come apart. I'm talking so big time dancing around on the timing strobes that were really the harmonic balancer jumping. The out of balance condition on the motor was so rough, I just knew it was a timing problem and even changed the distributor, wires, etc . The clue bird landed when I started removing the balancer to go into the timing chain. It all but fell apart in my hands!!!!

Trees
 

·
Shop Owner And Troll Hunter
Joined
·
2,643 Posts
That doesn't happen very often, but when it does it sure shakes the engine. I've seen it happen two times in my years working on cars.

Troy
 

·
Registered
Joined
·
327 Posts
troy-curt said:
That doesn't happen very often, but when it does it sure shakes the engine. I've seen it happen two times in my years working on cars.

Troy
on our jeep cherokee the serpentine belt was torn so I replaced it and a week later the new belt was torn. I noticed that the harmonic balancers outer ring was coming apart from the center and the belt was not running true and getting eaten up. changed it and let my girl total the car a short time later. ed ke6bnl
 

·
Registered
Joined
·
159 Posts
tm454 said:
My 74 Dodge PU with 98,600miles or could be198,600miles the timing jumps around with the timing light on the engine?? Won't settle down...hot or cold and only slightly when the engine reves up?? There is a bad bog upon acceleration till it warms up then it seems to accelerate better. I rebuilt the carb and installed a new accelerator pump and base gasket on the carb. What do you guys think the problem is here..like I said I have an idea but want opinions before I dig into this.


Tazz


Rat Rods Rule!
Unhook vac to dizzy hose, iff the timing light still erratick(all over the joint) its prob ya mechanical advance (bob weights and springs need lube (sticky) or brokin

Dont forget to block off the disconected vac hose ,

?? Is it an original 6 or 8 ???

I read all posts and realized it is an 318 or more x8 ,, 360 eng maybe,,
?? Is it sorted yet ??
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top