Hot Rod Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Wondering a lot about my truck. It’s a 1992 Silverado 2wd swb single cab 1500. Nothing fancy. I’m wondering about what’s all in it I’m pretty sure it’s mostly stock if not completely stock. How can I find out if these things are stock or not? Here’s what I want to know.
What’s the stock height in the front. (Mine sits low. Lower than my 95 gmc 1500. From center of wheel it’s 17in to the fender lip.
what kind of rear end did they have with the 4.3l and the 700r4 (I just swapped it to a 350 tbi out of a 95)
Ok that’s it on what I want to know if it’s stock Ik not a lot but curious.
another thing however is as I said I swapped the 4.3l to a 5.7 out of a 95. Well I’m having a hiccup. I took the truck for a test ride the other day and had a buddy following me it cut out and died and ended up causing an electrical fire that was quickly put out so no damage done except to plug wires and a starter wire. Got it fixed and drove it home with my buddy on the phone telling me I was blowing a constant blue flame out my exhaust so I pulled over and opened the hood to find both exhaust headers glowing red the drive was 2 miles. It had bad hesitation low power. I’ve adjusted the timing I don’t have a timing light or tach so I played it by ear. I’ve adjusted the valves but thinking I did them too tight. It also back fires out the tbi as well as the exhaust! It’s my first build 100% on my own and I’m really hoping I got everything right. Ik this is long and I’m asking for a lot of information but hopefully y’all with pull through. Thanks
-H
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
What distributor does the 5.7 have? Did you change the ecm? 5.7 will probably be different than the 4.3.
i changed the ecmto a new one from bumper2bumper for a 92 5.7l i was going to use the 4.3l prom but it gives me the code 51( improper prom) so I got a prom from a 89 5.7 and put it in same thing code 51. The distributor is just a oem one. I got my timing light to work. It’s an oldie apparently they are know to give ya a shock. But the timing is set 2 degrees retarded going to advance to 2 or 4 degrees.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Update truck runs better but still has major backfire and still a slight hesitation when slapping the throttle to the floor. I adjusted my valves as well and reset timing advanced 2*.
 

·
Hates: Liver. Loves: Diesel
Joined
·
6,026 Posts
The rear axle with the 4.3L should be an 8.5" 10 bolt. Plenty for a TBI 350.

Regarding the front height, are you measuring before the engine swap, or after you added 100 lbs to the front? The 5.7L trucks have different springs to account for the weight difference.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The rear axle with the 4.3L should be an 8.5" 10 bolt. Plenty for a TBI 350.

Regarding the front height, are you measuring before the engine swap, or after you added 100 lbs to the front? The 5.7L trucks have different springs to account for the weight difference.
I’m measuring before the swap. Is the rear end anti slip or positive track in those?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Truck runs great now still slight hesitation But jumps in a half second. and I found a small exhaust leak on the y pipe gonna have to weld it but that rules the back fire most likely, it’s also y pipe just past the o2 to a 28in glass pack and turn down tip. What could I use to lower the back end with out having to buy anything I’ve kinda went way way way over budget on it. The wife is not a happy camper..... but if she thinks I’m just workin on it and not spending money she’ll leave me alone lol.
 
1 - 8 of 8 Posts
Top