Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
259 Posts
Discussion Starter · #1 ·
Hi guy's, I know Jeep doesn't quite fit the Hot rod posts but there are alot of engine guy's in here that might be able to help or at least give me an Idea of where to start looking. I have a 2003 jeep Rubicon with a 426 hemi thats giving me a little problem. The engine is stock out of a 2007/8 Chrysler product and I bought it this way. My problem is it dies just while driving down the street. Im able to pull over and it starts right back up again with no problem and it might go another day or two and it happens again. Engine is stock with fuel injection and whoever put this in did an incredable job cuz it looks factory. Ive had it about 3 years and never had a problem till now. it occurs most often as Im backing off the accelerator pedal to slow down. Any Ideas would be greatly appreciated. Bill
 

·
current hot rod: CTS-V
Joined
·
1,821 Posts
It seems to be an issue for some with SRT-8s (same engine/ecu) Check out below, it's a 42 page thread, I didn't read through the whole thing but I expect it will provide some clarity for you. Unrelated but relevant, my friend was having a similar issue with a factory turbocharged Mazda. I found a TSB for him that was for updating the maps for the fuel pump, the dealership re-flashed his ecu with the latest software and it solved his problems.

Engine Stalling? - Dodge Challenger Forum: Challenger & SRT8 Forums
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top