Hot Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
i hope that this will be the last post for this 97 geo metro. i need to move on to better things. the last time i posted a message, i was having problems with this metro of my wife's where it was wanting to not start after it has been running. a couple of you out there suggested that the egr was at fault. since that post, i tested and cleaned out the egr valve and replaced a special vac./ elec. post that is located under the egr modulator. i got out to run it and the dumb thing again acted up. it is only doing this when the weather is warm or hot. upon returning from the local grocery store, it would run fine for a couple of minutes and then start sputtering. the engine would all of a sudden drop to its idle speed and if i try to give it gas, the engine would act all retarded like it was getting too much gas. as soon as the car would coast to a stop, the car would die. i would have to get out and take off the air filter cover and it would restart (most of the time). it is getting gas and is falling in the specs. for fuel pressure. what am i missing here? it is something so close and in all likely hood very simple but i am missing it. help?
 

·
E.T. divided by $ spent= Speed
Joined
·
1,855 Posts
monte's cure all guide to FI computer engines

Plugs,wires,cap,rotor and fuel filter if it don't run then,flat tow it to Pep Boy's.
 

·
Registered
Joined
·
127 Posts
I once had a geo storm, they had the notorious problem of when the ECU was made a coating was sprayed on the top of the circuit board, but a few years down the road the substance sprayed on the circuit board expanded when it got hot and broke a few solders, caused and effect like that, it was a *****, i also had a problem where i couldn't go over a certain rmp or it would just die, acted up after it was hot, solution to that one, Ingnition Module i tested my old one and they said it was still good i said screw it i'll just get a new one anyways, sure as **** i never had a problem till i hurled it down a ditch and totaled the damn thing!!!!!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I MAY HAVE TO AGREE WITH THAT ONE. WHATEVER THE PROBLEM IS, I FIGURE THAT IT IS ELECTRONIC IN NATURE (ONLY SHUTS DOWN IN THE HEAT OR WHEN IT GETS REAL HOT UNDE THE HOOD) AND THE WAY IT ACTS WHEN THIS HAPPENS. ENGINE GOES TO A IDLE MODE AND IF YOU PRESS ON THE GAS PEDAL TO GO AGAIN, THE ENGINE WILL DEACELLERATE. ******THING I HAVE EVER SEEN. ACTS LIKE A VAPOR LOCK.
 

·
Registered
Joined
·
157 Posts
Might not hurt to run a compression test, so you know where you stand there.

I don't know if the '97 Geo Metro still had the 3 cyl. engine or not. If so, I'll warn you that the exhaust valves are notorious for either burning or warping.

When you have the head done, plan on 3 new exh. valves.....the intakes most likely can be reground.
 
1 - 5 of 5 Posts
Top